aboutsummaryrefslogtreecommitdiffstats
path: root/main/qemu/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-26 16:23:40 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-27 11:18:18 +0000
commit41e38db75810a3d58005c6f1f3745e117c5011a6 (patch)
treecf11cb19343da2b53c8cfc6e7b56cf0178c2deb6 /main/qemu/APKBUILD
parentd9a924f2e457e76b4a6a3eba2a03e8dc8203340a (diff)
downloadaports-41e38db75810a3d58005c6f1f3745e117c5011a6.tar.bz2
aports-41e38db75810a3d58005c6f1f3745e117c5011a6.tar.xz
main/qemu: fix chown/chmod for qemu-bridge-helper and gid of qemu group
gid 35 is already reserved for group "games"
Diffstat (limited to 'main/qemu/APKBUILD')
-rw-r--r--main/qemu/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 6754b6fdbf..6824403bc4 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
pkgver=2.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://qemu.org/"
arch="all"
@@ -219,8 +219,8 @@ package() {
# qemu-bridge-helper needs suid to create tunX devices;
# allow only users in the qemu group to run it.
- chmod 04710 "$pkgdir"/usr/libexec/qemu/qemu-bridge-helper
- chgrp qemu "$pkgdir"/usr/libexec/qemu/qemu-bridge-helper
+ chmod 04710 "$pkgdir"/usr/lib/qemu/qemu-bridge-helper || return 1
+ chgrp qemu "$pkgdir"/usr/lib/qemu/qemu-bridge-helper || return 1
if [ -n "$_arch" ]; then
cd "$builddir"/build-gtk