aboutsummaryrefslogtreecommitdiffstats
path: root/main/qemu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-12-02 07:55:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-12-02 08:00:45 +0000
commit0548e34a20c5d9fb51e80fb6eb38e068fb168323 (patch)
treec34a044906835be67c0c5592802b1d49b5e84271 /main/qemu
parent55f6e4065b6ec918ca869b11a27b1f1edaf3a84a (diff)
downloadaports-0548e34a20c5d9fb51e80fb6eb38e068fb168323.tar.bz2
aports-0548e34a20c5d9fb51e80fb6eb38e068fb168323.tar.xz
main/qemu: add snappy, libnfs support and use upstream CFLAGS
we disable our custom CFLAGS in an attempt to try catch a bug reported by pluesh on irc.
Diffstat (limited to 'main/qemu')
-rw-r--r--main/qemu/APKBUILD57
1 files changed, 43 insertions, 14 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 8abff203d6..97e6dbdfad 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -1,16 +1,39 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
pkgver=2.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://qemu.org/"
arch="all"
license="GPL2 LGPL-2"
-makedepends="zlib-dev alsa-lib-dev gnutls-dev ncurses-dev glib-dev
- libjpeg-turbo-dev libpng-dev vde2-dev spice-dev paxmark curl-dev
- libcap-dev libcap-ng-dev libaio-dev usbredir-dev util-linux-dev
- libusb-dev flex bison linux-headers libssh2-dev
- gtk+3.0-dev"
+makedepends="
+ alsa-lib-dev
+ bison
+ curl-dev
+ flex
+ glib-dev
+ gnutls-dev
+ gtk+3.0-dev
+ libaio-dev
+ libcap-dev
+ libcap-ng-dev
+ libjpeg-turbo-dev
+ libnfs-dev
+ libpng-dev
+ libssh2-dev
+ libusb-dev
+ linux-headers
+ lzo-dev
+ ncurses-dev
+ paxmark
+ snappy-dev
+ spice-dev
+ usbredir-dev
+ util-linux-dev
+ vde2-dev
+ xfsprogs-dev
+ zlib-dev
+ "
depends=
install="qemu.pre-install"
subpackages="
@@ -108,13 +131,9 @@ prepare() {
esac
done
- # avoid fdt till an updated release appears
- sed -i -e 's:fdt="yes":fdt="no":' configure
# prevent docs to get automatically installed
sed -i '/$(DESTDIR)$(docdir)/d' Makefile
- # Alter target makefiles to accept CFLAGS
- sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- Makefile Makefile.target tests/Makefile
+
sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
Makefile.target
}
@@ -125,6 +144,8 @@ _compile() {
--localstatedir=/var \
--sysconfdir=/etc \
--libexecdir=/usr/lib/qemu \
+ --audio-drv-list=oss,alsa \
+ --enable-kvm \
--enable-vde \
--enable-virtfs \
--enable-curl \
@@ -134,10 +155,18 @@ _compile() {
--enable-uuid \
--enable-libssh2 \
--enable-vhost-net \
+ --enable-pie \
+ --enable-snappy \
+ --enable-tpm \
+ --enable-libnfs \
+ --enable-lzo \
+ --disable-glusterfs \
+ --disable-debug-info \
--disable-bsd-user \
--disable-werror \
--disable-smartcard-nss \
--disable-sdl \
+ --disable-xen \
--cc="${CC:-gcc}" \
"$@" \
|| return 1
@@ -151,16 +180,17 @@ build() {
_compile \
--enable-vnc \
+ --enable-vnc-png \
+ --enable-vnc-tls \
--enable-spice \
--enable-linux-user \
--enable-guest-agent \
- --audio-drv-list=oss,alsa \
--disable-gtk \
|| return 1
# tests fails on x86
# http://lists.gnu.org/archive/html/qemu-devel/2012-11/msg01429.html
-# http://web.archiveorange.com/archive/v/21oVv8wOfpQGkyy8EK0N
+# http://web.archiveorange.com/archive/v/21oVv8wOfpQGkyy8EK0N
# make check || return 1
if [ -z "$_arch" ]; then
@@ -169,7 +199,6 @@ build() {
cd "$srcdir"/qemu-$pkgver/build-gtk
_compile \
- --audio-drv-list=oss,alsa \
--enable-gtk \
--with-gtkabi=3.0 \
--disable-linux-user \