aboutsummaryrefslogtreecommitdiffstats
path: root/main/qt/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-04-09 09:08:31 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-04-09 09:08:31 +0000
commit96398ac58d99a047a9a6c3f87c8929cdc0bfecdd (patch)
tree64e15a921769ac374db84a45bae7989618c821f3 /main/qt/APKBUILD
parent168226e868aae07f904d421276df5a71bd2c9bb5 (diff)
downloadaports-96398ac58d99a047a9a6c3f87c8929cdc0bfecdd.tar.bz2
aports-96398ac58d99a047a9a6c3f87c8929cdc0bfecdd.tar.xz
main/qt: use paxmark
Diffstat (limited to 'main/qt/APKBUILD')
-rw-r--r--main/qt/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/qt/APKBUILD b/main/qt/APKBUILD
index 6d3e825157..eeb0010fe7 100644
--- a/main/qt/APKBUILD
+++ b/main/qt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt
pkgver=4.8.6
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application and UI framework"
url="http://qt-project.org/"
arch="all"
@@ -18,7 +18,7 @@ depends_dev="mesa-dev libice-dev libsm-dev libx11-dev libxext-dev
glib-dev libpng-dev zlib-dev sqlite-dev dbus-dev"
makedepends="$depends_dev postgresql-dev mariadb-dev unixodbc-dev cups-dev
gtk+-dev tiff-dev libmng-dev libxrandr-dev libxv-dev libxi-dev perl
- gawk paxctl rsync freetds-dev hicolor-icon-theme mesa-gl"
+ gawk paxmark rsync freetds-dev hicolor-icon-theme mesa-gl"
install=
source="http://download.qt-project.org/official_releases/qt/4.8/$pkgver/qt-everywhere-opensource-src-$pkgver.tar.gz
qt-gtk-theme-fix.patch
@@ -106,10 +106,9 @@ build() {
package() {
cd "$_builddir"
make INSTALL_ROOT="$pkgdir" install
- rm -r "$pkgdir"/usr/lib/*.la \
- "$pkgdir"/usr/tests || return 1
+ rm -r "$pkgdir"/usr/tests || return 1
- paxctl -cm "$pkgdir"/usr/bin/qmlviewer "$pkgdir"/usr/bin/designer \
+ paxmark -m "$pkgdir"/usr/bin/qmlviewer "$pkgdir"/usr/bin/designer \
|| return 1
# install missing icons and desktop files