aboutsummaryrefslogtreecommitdiffstats
path: root/main/qt5-qtbase
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-30 12:22:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-30 13:14:51 +0000
commit7494b7c4712ab85697fd89db2da7af789dbe0e46 (patch)
tree28ae4b49cd8fb41e94e1309b6be4b88e38b67502 /main/qt5-qtbase
parentd6b018780eed364a08b3aa204ea0737d2e305b77 (diff)
downloadaports-7494b7c4712ab85697fd89db2da7af789dbe0e46.tar.bz2
aports-7494b7c4712ab85697fd89db2da7af789dbe0e46.tar.xz
main/qt5-qtbase: disable reduce-relocations
gcc5 and PIE does not work well with reduce relocations https://bugs.archlinux.org/task/45283
Diffstat (limited to 'main/qt5-qtbase')
-rw-r--r--main/qt5-qtbase/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/qt5-qtbase/APKBUILD b/main/qt5-qtbase/APKBUILD
index aaf040dc5f..e53fe3d94c 100644
--- a/main/qt5-qtbase/APKBUILD
+++ b/main/qt5-qtbase/APKBUILD
@@ -5,7 +5,7 @@ _ver=${pkgver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
_V=${_ver/rc/RC}
-pkgrel=0
+pkgrel=1
pkgdesc="Qt5 - QtBase components"
url="http://qt-project.org/"
arch="all"
@@ -79,11 +79,6 @@ build() {
cd "$_builddir"
- case "$CTARGET" in
- arm*) _arch="";;
- *) _arch="-reduce-relocations";;
- esac
-
./configure -confirm-license -opensource \
-archdatadir "$_qt5_prefix" \
-bindir "$_qt5_prefix"/bin \
@@ -120,7 +115,7 @@ build() {
-system-xcb \
-system-zlib \
-translationdir "$_qt5_datadir"/translations \
- $_arch \
+ -no-reduce-relocations \
|| return 1
make || return 1
}