aboutsummaryrefslogtreecommitdiffstats
path: root/main/raspberrypi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-08-27 11:03:15 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-08-27 11:20:35 +0000
commitedefd680f694895f1c9cc335381db3c243a59990 (patch)
tree32c3ffa676fcc3d61e931389352648fc32d76ab1 /main/raspberrypi
parent7ead7994c5b4e9e1cd5bbca252b1645a52a83998 (diff)
downloadaports-edefd680f694895f1c9cc335381db3c243a59990.tar.bz2
aports-edefd680f694895f1c9cc335381db3c243a59990.tar.xz
main/raspberrypi: update snapshot, fix build
- linux-headers is -dev dependency - patch errors detected by gcc5.1 - workaround gcc5.1 warning (that gets treated as error)
Diffstat (limited to 'main/raspberrypi')
-rw-r--r--main/raspberrypi/APKBUILD31
-rw-r--r--main/raspberrypi/fix-inlines.patch26
2 files changed, 46 insertions, 11 deletions
diff --git a/main/raspberrypi/APKBUILD b/main/raspberrypi/APKBUILD
index d3056dca82..89a0b8d712 100644
--- a/main/raspberrypi/APKBUILD
+++ b/main/raspberrypi/APKBUILD
@@ -1,19 +1,21 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=raspberrypi
-pkgver=0.20150526
-_commitid=d4aa617de3b196399bb8e2ce32e181768cb52179
+pkgver=0.20150825
+_commitid=fb11b39d97371c076eef7c85bbcab5733883a41e
pkgrel=0
pkgdesc="Raspberry Pi support tools"
url="https://github.com/raspberrypi/userland"
arch="armhf"
license="BSD"
-depends="linux-headers"
-makedepends="cmake"
+depends=""
+depends_dev="linux-headers"
+makedepends="cmake $depends_dev"
install=""
options="!fhs"
subpackages="$pkgname-dev $pkgname-libs"
source="raspberrypi-$pkgver.tar.gz::https://github.com/raspberrypi/userland/archive/$_commitid.tar.gz
fix-build.patch
+ fix-inlines.patch
"
_sourcedir="$srcdir"/userland-$_commitid
@@ -32,7 +34,11 @@ prepare() {
build() {
mkdir -p "$_builddir"
cd "$_builddir"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_RPATH=/opt/vc/lib $_sourcedir || return 1
+ # -Wno-error=array-bounds is workaround for gcc bug 59124
+ cmake -DCMAKE_C_FLAGS="$CFLAGS -D_GNU_SOURCE -Wno-error=array-bounds" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_RPATH=/opt/vc/lib \
+ $_sourcedir || return 1
make
}
@@ -52,9 +58,12 @@ libs() {
mv "$pkgdir"/opt/vc/lib/* "$subpkgdir"/opt/vc/lib
}
-md5sums="5d9885f0f6647223aa7adc0b8f03f924 raspberrypi-0.20150526.tar.gz
-5e2f8c8f8d59541370b7df4918352443 fix-build.patch"
-sha256sums="9f6959e80460fb3b0626712f59c0fc3b647281066d77bad881f5765834823c61 raspberrypi-0.20150526.tar.gz
-90610f473acb5267eff18baaaca39076401dd375156ce2bf2e220738fac0ee99 fix-build.patch"
-sha512sums="05396cb2b0c6440c37c37ccb408667207e9c76ce4ffdbf373f620b2fcb274d614c02eec888f972524bcfab94cda412b7969abb7ce627a72893b94673a5411c9d raspberrypi-0.20150526.tar.gz
-8697565069613dc824a516784553eb0ea5edcaa072dfc57fc38c32d0d7f6051273a2eedae840e8909fd046bf828eb4aaa50c2fff31c371c9ef23b7d4f33450aa fix-build.patch"
+md5sums="892449f3d18208da4ea2f871c21c8e35 raspberrypi-0.20150825.tar.gz
+5e2f8c8f8d59541370b7df4918352443 fix-build.patch
+87d5150f912486b7dadfee05d1f034cb fix-inlines.patch"
+sha256sums="3521fa369732c7caa9a343c19a4b37d1b1056033965f0654a07547a936da87df raspberrypi-0.20150825.tar.gz
+90610f473acb5267eff18baaaca39076401dd375156ce2bf2e220738fac0ee99 fix-build.patch
+cae600ccfcbf3699e4e968352d5c483536bdab0a1b0700fc40b620bf3b6e50a6 fix-inlines.patch"
+sha512sums="806c888e5a927204c817fc25a0bc91a1cedb0f2385ccb2c54de5c966e8dc59cf1277e51b3fd9bb005352995d9f725b9be6c357499121e634ec9332b35fee9fb0 raspberrypi-0.20150825.tar.gz
+8697565069613dc824a516784553eb0ea5edcaa072dfc57fc38c32d0d7f6051273a2eedae840e8909fd046bf828eb4aaa50c2fff31c371c9ef23b7d4f33450aa fix-build.patch
+1b54703bb63f995f7c9b80801975302d7e6df4f396e1213dff3004d399e60cde2714c46480555e935e793e168865e44964514a3d41dfd7a1fb74759f7ce65c7e fix-inlines.patch"
diff --git a/main/raspberrypi/fix-inlines.patch b/main/raspberrypi/fix-inlines.patch
new file mode 100644
index 0000000000..57f35183d7
--- /dev/null
+++ b/main/raspberrypi/fix-inlines.patch
@@ -0,0 +1,26 @@
+--- userland-fb11b39d97371c076eef7c85bbcab5733883a41e.orig/interface/vcos/vcos_types.h
++++ userland-fb11b39d97371c076eef7c85bbcab5733883a41e/interface/vcos/vcos_types.h
+@@ -121,10 +121,10 @@
+ #if defined(NDEBUG)
+
+ #ifdef __GNUC__
+-# define VCOS_INLINE_DECL extern __inline__
++# define VCOS_INLINE_DECL extern
+ # define VCOS_INLINE_IMPL static __inline__
+ #else
+-# define VCOS_INLINE_DECL static _VCOS_INLINE /* declare a func */
++# define VCOS_INLINE_DECL extern
+ # define VCOS_INLINE_IMPL static _VCOS_INLINE /* implement a func inline */
+ #endif
+
+--- userland-fb11b39d97371c076eef7c85bbcab5733883a41e.orig/interface/vcos/pthreads/vcos_platform_types.h
++++ userland-fb11b39d97371c076eef7c85bbcab5733883a41e/interface/vcos/pthreads/vcos_platform_types.h
+@@ -61,7 +61,7 @@
+ #define VCOS_ASSERT_MSG(...) ((VCOS_ASSERT_LOGGING && !VCOS_ASSERT_LOGGING_DISABLE) ? vcos_pthreads_logging_assert(__FILE__, __func__, __LINE__, __VA_ARGS__) : (void)0)
+
+ #define VCOS_INLINE_BODIES
+-#define VCOS_INLINE_DECL extern __inline__
++#define VCOS_INLINE_DECL extern
+ #define VCOS_INLINE_IMPL static __inline__
+
+ #ifdef __cplusplus