aboutsummaryrefslogtreecommitdiffstats
path: root/main/rhash/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-12 15:54:14 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-12 15:54:14 +0200
commite77e6d16efecb4c179efa741c543ff9facf52c5a (patch)
treed5b3b218f98a885b7f06f2eacce982da7d5b8265 /main/rhash/APKBUILD
parent25e6e0f5d1a2033824cea870d713c072b430c23a (diff)
downloadaports-e77e6d16efecb4c179efa741c543ff9facf52c5a.tar.bz2
aports-e77e6d16efecb4c179efa741c543ff9facf52c5a.tar.xz
main/rhash: move from community (need for cmake)
Diffstat (limited to 'main/rhash/APKBUILD')
-rw-r--r--main/rhash/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/rhash/APKBUILD b/main/rhash/APKBUILD
new file mode 100644
index 0000000000..8eb99c7518
--- /dev/null
+++ b/main/rhash/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Przemyslaw Pawelczyk <przemoc@zoho.com>
+pkgname=rhash
+pkgver=1.3.4
+pkgrel=1
+pkgdesc="Utility for calculation and verification of hash sums and magnet links"
+url="http://rhash.anz.ru/"
+arch="all"
+license="custom"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz
+ librhash-byte_order.h-Consult-also-compiler-s-predef.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+md5sums="0b51010604659e9e99f6307b053ba13b rhash-1.3.4.tar.gz
+59a1c0a0d04a7b4356a8b893dce7c266 librhash-byte_order.h-Consult-also-compiler-s-predef.patch"
+sha256sums="406662c4703bd4cb1caae26f32700951a5e12adf39f141d3f40e0b461b1e9e49 rhash-1.3.4.tar.gz
+19561529fdd2ccb1aaf54b0459962f969b7eadccd4119d8e4c94dadd8ed24589 librhash-byte_order.h-Consult-also-compiler-s-predef.patch"
+sha512sums="a78be309011798d5e55023eb93f898c10254a42270288fa5ec68ad446b5f3d001e8c6f893683e5171e3858c86d45ce2ce16eefde1173209e1925420c27a7ff7a rhash-1.3.4.tar.gz
+5d14156b42d41f976f605d0e07fe9ae5cf5cb2266f65e2ab09690b2bb992d348317c0e115c81015ff645eb25ff556e628d1ebc268ced816c5f192c0cc83e3ed1 librhash-byte_order.h-Consult-also-compiler-s-predef.patch"