aboutsummaryrefslogtreecommitdiffstats
path: root/main/rsyslog
diff options
context:
space:
mode:
authorChristian Kampka <christian@kampka.net>2016-07-13 19:31:20 +0200
committerChristian Kampka <christian@kampka.net>2016-07-13 19:31:20 +0200
commitfe74d94d5f16e4cec728d7a315ccf40b06e18b92 (patch)
treede62bf3a2cf38aeb862cbd859c360f0a3b3397df /main/rsyslog
parent536c0fad0f88195a607f4fd1f8c8c874f79af921 (diff)
downloadaports-fe74d94d5f16e4cec728d7a315ccf40b06e18b92.tar.bz2
aports-fe74d94d5f16e4cec728d7a315ccf40b06e18b92.tar.xz
main/rsyslog: new upstream version 8.20.0
Diffstat (limited to 'main/rsyslog')
-rw-r--r--main/rsyslog/8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch114
-rw-r--r--main/rsyslog/APKBUILD18
2 files changed, 7 insertions, 125 deletions
diff --git a/main/rsyslog/8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch b/main/rsyslog/8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch
deleted file mode 100644
index c763780f1a..0000000000
--- a/main/rsyslog/8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch
+++ /dev/null
@@ -1,114 +0,0 @@
-From 8e4bfe19b5d971f5df8520faf8753381b58e7ca7 Mon Sep 17 00:00:00 2001
-From: Rainer Gerhards <rgerhards@adiscon.com>
-Date: Fri, 29 Apr 2016 08:09:44 +0200
-Subject: [PATCH] core: set default stack size to 4MiB
-
-Note that this is below the usual 10MiB default, but should cause
-no issues (output threads already use 4MiB stack size, for example).
-This also addresses issues introduced by micro-libc's which only
-provide very limited stack space by default.
-
-closes https://github.com/rsyslog/rsyslog/issues/996
----
- runtime/rsyslog.c | 7 ++++---
- runtime/rsyslog.h | 2 +-
- runtime/stream.c | 4 ----
- threads.c | 9 +--------
- 4 files changed, 6 insertions(+), 16 deletions(-)
-
-diff --git a/runtime/rsyslog.c b/runtime/rsyslog.c
-index c6d70d4..c23d9f7 100644
---- a/runtime/rsyslog.c
-+++ b/runtime/rsyslog.c
-@@ -35,7 +35,7 @@
- *
- * Module begun 2008-04-16 by Rainer Gerhards
- *
-- * Copyright 2008-2014 Rainer Gerhards and Adiscon GmbH.
-+ * Copyright 2008-2016 Rainer Gerhards and Adiscon GmbH.
- *
- * This file is part of the rsyslog runtime library.
- *
-@@ -83,9 +83,9 @@
- #include "atomic.h"
- #include "srUtils.h"
-
-+pthread_attr_t default_thread_attr;
- #ifdef HAVE_PTHREAD_SETSCHEDPARAM
- struct sched_param default_sched_param;
--pthread_attr_t default_thread_attr;
- int default_thr_sched_policy;
- #endif
-
-@@ -145,11 +145,12 @@ rsrtInit(char **ppErrObj, obj_if_t *pObjIF)
- stdlog_init(0);
- stdlog_hdl = NULL;
- #endif
-+ CHKiRet(pthread_attr_init(&default_thread_attr));
-+ pthread_attr_setstacksize(&default_thread_attr, 4096*1024);
- #ifdef HAVE_PTHREAD_SETSCHEDPARAM
- CHKiRet(pthread_getschedparam(pthread_self(),
- &default_thr_sched_policy,
- &default_sched_param));
-- CHKiRet(pthread_attr_init(&default_thread_attr));
- CHKiRet(pthread_attr_setschedpolicy(&default_thread_attr,
- default_thr_sched_policy));
- CHKiRet(pthread_attr_setschedparam(&default_thread_attr,
-diff --git a/runtime/rsyslog.h b/runtime/rsyslog.h
-index 542343d..87198f3 100644
---- a/runtime/rsyslog.h
-+++ b/runtime/rsyslog.h
-@@ -532,9 +532,9 @@ typedef enum rsObjectID rsObjID;
- #define RSFREEOBJ(x) {(x)->OID = OIDrsFreed; free(x);}
- #endif
-
-+extern pthread_attr_t default_thread_attr;
- #ifdef HAVE_PTHREAD_SETSCHEDPARAM
- extern struct sched_param default_sched_param;
--extern pthread_attr_t default_thread_attr;
- extern int default_thr_sched_policy;
- #endif
-
-diff --git a/runtime/stream.c b/runtime/stream.c
-index ae3efaa..97b0ccd 100644
---- a/runtime/stream.c
-+++ b/runtime/stream.c
-@@ -968,11 +968,7 @@ static rsRetVal strmConstructFinalize(strm_t *pThis)
- pThis->pIOBuf = pThis->asyncBuf[0].pBuf;
- pThis->bStopWriter = 0;
- if(pthread_create(&pThis->writerThreadID,
--#ifdef HAVE_PTHREAD_SETSCHEDPARAM
- &default_thread_attr,
--#else
-- NULL,
--#endif
- asyncWriterThread, pThis) != 0)
- DBGPRINTF("ERROR: stream %p cold not create writer thread\n", pThis);
- } else {
-diff --git a/threads.c b/threads.c
-index b6cab1b..2d83402 100644
---- a/threads.c
-+++ b/threads.c
-@@ -235,7 +235,6 @@ static void* thrdStarter(void *arg)
- ENDfunc
- pthread_exit(0);
- }
--
- /* Start a new thread and add it to the list of currently
- * executing threads. It is added at the end of the list.
- * rgerhards, 2007-12-14
-@@ -253,13 +252,7 @@ rsRetVal thrdCreate(rsRetVal (*thrdMain)(thrdInfo_t*), rsRetVal(*afterRun)(thrdI
- pThis->pAfterRun = afterRun;
- pThis->bNeedsCancel = bNeedsCancel;
- pThis->name = ustrdup(name);
-- pthread_create(&pThis->thrdID,
--#ifdef HAVE_PTHREAD_SETSCHEDPARAM
-- &default_thread_attr,
--#else
-- NULL,
--#endif
-- thrdStarter, pThis);
-+ pthread_create(&pThis->thrdID, &default_thread_attr, thrdStarter, pThis);
- CHKiRet(llAppend(&llThrds, NULL, pThis));
-
- finalize_it:
diff --git a/main/rsyslog/APKBUILD b/main/rsyslog/APKBUILD
index d98dd62786..07397342a9 100644
--- a/main/rsyslog/APKBUILD
+++ b/main/rsyslog/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Ashley Sommer <ashleysommer@gmail.com>
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=rsyslog
-pkgver=8.18.0
+pkgver=8.20.0
pkgrel=0
pkgdesc="Enhanced multi-threaded syslogd with database support and more."
url="http://www.rsyslog.com/"
@@ -23,7 +23,6 @@ source="http://www.rsyslog.com/files/download/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname.conf
musl-fix.patch
queue.patch
- 8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -109,27 +108,24 @@ snmp() {
"$subpkgdir"/usr/lib/rsyslog/ || return 1
}
-md5sums="750d552bdcbf255c85f464ffbe21168a rsyslog-8.18.0.tar.gz
+md5sums="dfa9a5a1aa8cd0960c1d7ecb1e3924c9 rsyslog-8.20.0.tar.gz
67b8afd572b4103b39b54a729b880b53 rsyslog.initd
a34f33d8f798ab6652b347ad09656284 rsyslog.confd
bc43debc9ffdf66bc1409025fd3d1176 rsyslog.logrotate
bc0a9b1095f5f6ffc937cd2c9bd26dff rsyslog.conf
480f153508fd10d157cefc0bb898fe2d musl-fix.patch
-dece4c5510e5d4f88293eff74da5bf57 queue.patch
-0d32cadf752462f45bcde9b04df9ebfc 8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch"
-sha256sums="94346237ecfa22c9f78cebc3f18d59056f5d9846eb906c75beaa7e486f02c695 rsyslog-8.18.0.tar.gz
+dece4c5510e5d4f88293eff74da5bf57 queue.patch"
+sha256sums="339c8f848238459318bf742d1c7a48854f98418fd3a7909030b614c395165b17 rsyslog-8.20.0.tar.gz
223d4bdb69760ef5a9a044d68434c805cd15e31fa190a86f5f283912d0baf6d6 rsyslog.initd
f93cd477770872486185152454ce66e89302b7a8d7a112ff285ceea892dfe1f1 rsyslog.confd
f0effc19bd1f1bfa367d65d6516c73509cb34545157b9e91cf6e437685dd3fe5 rsyslog.logrotate
e4ebe806b5a71edaa4492033ea3a3e70810a64d3f3d4f4e9954eefcf25f2e2ed rsyslog.conf
5b8420570bef57aeba55965bbbddb29f966b60a33ef9e7fc5f921820274080b0 musl-fix.patch
-8d6dda439c79dffac2a5d17e3d9a28355cfb8fc264175a871e27304ace259daa queue.patch
-940dcb4a48cbb8e235cab8c35dbb10c32bc6283574fe845dcce42a428a92ee3b 8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch"
-sha512sums="6b159ba23100b4675576f5b247d2bf482bab0beaa071c26c692c99e50f202b0b272b7a64ba2b7c726390d663677b7a6d68666b06f73825e35605b13ae0930fc7 rsyslog-8.18.0.tar.gz
+8d6dda439c79dffac2a5d17e3d9a28355cfb8fc264175a871e27304ace259daa queue.patch"
+sha512sums="179b61e4d5393633909bf718cf9b187d34161e9e4395fa2577cfc4f2c35a50e3f9128de376b1a0bb9dc3dd112857d377e553f10e5332719df35e98f9cd631e2b rsyslog-8.20.0.tar.gz
9a4b184076a82e0899da79ab3749e1c67eac03f36c4460d34ed0385f4a3ffad53681a1cc25dd514e835c9399a9abd01c235743535ad549d5be7f66d9e127b9dc rsyslog.initd
a4d969671800227129be870b0318961b79d16365663754111a136734bbf7005abd4da24853dfdc07b3b6691ab5a7b215f0ac6c19022b4c5c8dab06165a42431b rsyslog.confd
d54377ddf39197656811a84272568ea761f984e19dd04fc54f372dd04a9244e66d02b26ab33073d0344d054f031660ec611f3c7a18c266e7b68cef5e2c47f06f rsyslog.logrotate
3bcd58b222eb7f4d8a42a0643cacb6ab44790f90c9bd550678e002bc19863d5d6a7341e5e5ba0b9292f85c6c04cd5cc42d174acdc63e8ba22022620db10f2b9b rsyslog.conf
20967235e8233588210071a7157a81fe02a1e88d7c7f55855fcc2fe34295269a6e3e3bfccb3d4dd83a6a48da28948c92d6ce47a0c5d817f6b6a4030635f4f896 musl-fix.patch
-de8b82781af2dfef67b2215782721cca2ee5db9d08ed3260f4e3390353a59bf4bd76701df682c4bf537ce817eabf79b062c4b2a3e20e4175e7d77ca08c5a700f queue.patch
-53e1b3a219fec91bf13448398bda6239061027dbd5327260fd44d9e3b290386b43992c3a0d20e73971c5f5a682b9bd87d17ffbf42d40121d82c079970b325547 8e4bfe19b5d971f5df8520faf8753381b58e7ca7.patch"
+de8b82781af2dfef67b2215782721cca2ee5db9d08ed3260f4e3390353a59bf4bd76701df682c4bf537ce817eabf79b062c4b2a3e20e4175e7d77ca08c5a700f queue.patch"