aboutsummaryrefslogtreecommitdiffstats
path: root/main/ruby
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-02-13 01:27:26 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-02-13 01:37:44 +0100
commitf92bb1fb18b060944107253b4713066f9768cc9a (patch)
tree112873db6608303eb6e5d6019f61f1eedb8295ed /main/ruby
parentadecbcd9dba9c9aa811c25e020e155c2246b16d8 (diff)
downloadaports-f92bb1fb18b060944107253b4713066f9768cc9a.tar.bz2
aports-f92bb1fb18b060944107253b4713066f9768cc9a.tar.xz
main/ruby: remove gems cache
Diffstat (limited to 'main/ruby')
-rw-r--r--main/ruby/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index f1cf294607..dd4af36b09 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby
pkgver=2.3.3
_abiver=2.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
arch="all"
@@ -78,6 +78,11 @@ package() {
make DESTDIR="$pkgdir" install || return 1
+ install -m 644 -D COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING || return 1
+
+ rm -R "$pkgdir"$_gemdir/cache/*
+
if [ -d "$pkgdir"/usr/local ]; then
local f=$(cd "$pkgdir" ; find usr/local -type f)
if [ -n "$f" ]; then
@@ -86,7 +91,6 @@ package() {
return 1
fi
fi
- install -m 644 -D COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
rake() {