aboutsummaryrefslogtreecommitdiffstats
path: root/main/ruby
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-18 04:23:44 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:50 +0000
commit83e4ddc711b08f5e0456d1b6087224145cefe9ac (patch)
tree4f658982c46fa0ac9511c2a8b1fac127d231a830 /main/ruby
parent847946acbfc0dfafcf4cbe920e53adef9be513a8 (diff)
downloadaports-83e4ddc711b08f5e0456d1b6087224145cefe9ac.tar.bz2
aports-83e4ddc711b08f5e0456d1b6087224145cefe9ac.tar.xz
main/ruby: modernise, move 'make test' to check phase
Diffstat (limited to 'main/ruby')
-rw-r--r--main/ruby/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index 0e94aa353a..d4b7c96f98 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -4,7 +4,7 @@
pkgname=ruby
pkgver=2.4.1
_abiver="${pkgver%.*}.0"
-pkgrel=4
+pkgrel=5
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
arch="all"
@@ -44,7 +44,7 @@ case "$CARCH" in
esac
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
autoconf
@@ -78,19 +78,22 @@ build() {
--enable-pthread \
--disable-rpath \
--enable-shared \
- --with-mantype=man \
- || return 1
- make || return 1
- make test || return 1
+ --with-mantype=man
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -m 644 -D COPYING \
- "$pkgdir"/usr/share/licenses/$pkgname/COPYING || return 1
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
rm -R "$pkgdir"$_gemdir/cache/*