aboutsummaryrefslogtreecommitdiffstats
path: root/main/screen
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-01-18 08:49:21 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-25 02:50:44 +0100
commit9476d27a258f9f927e599c35f0a5c31078d21008 (patch)
tree85f7545fb7f49f14e97c87ce4eeb342bfc3d34a9 /main/screen
parent081aed6c6393cca9b4edaf309e27f4e960502b82 (diff)
downloadaports-9476d27a258f9f927e599c35f0a5c31078d21008.tar.bz2
aports-9476d27a258f9f927e599c35f0a5c31078d21008.tar.xz
main/screen: upgrade to 4.5.0
Diffstat (limited to 'main/screen')
-rw-r--r--main/screen/APKBUILD12
-rw-r--r--main/screen/CVE-2015-6806.patch52
2 files changed, 5 insertions, 59 deletions
diff --git a/main/screen/APKBUILD b/main/screen/APKBUILD
index 8bb5ef53b7..680367bce5 100644
--- a/main/screen/APKBUILD
+++ b/main/screen/APKBUILD
@@ -1,19 +1,17 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=screen
-pkgver=4.4.0
+pkgver=4.5.0
pkgrel=0
pkgdesc="A window manager that multiplexes a physical terminal"
url="http://ftp.gnu.org/gnu/screen/"
arch="all"
license="GPL3+"
-depends=""
makedepends="ncurses-dev ncurses"
-install=""
subpackages="$pkgname-doc"
source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
./configure \
@@ -39,6 +37,6 @@ package() {
install -Dm644 etc/screenrc "$pkgdir"/etc/skel/.screenrc || return 1
}
-md5sums="d26e11a3648c2b11aaefa215a55dfd39 screen-4.4.0.tar.gz"
-sha256sums="ef722a54759a3bf23aad272bbf33c414c1078cad6bcd982fada93c0d7917218b screen-4.4.0.tar.gz"
-sha512sums="6e43f85c419f778822ec85e4340c95769e981a3d51abdeb5f26c6ebb840da9ab11b351ecc7f380ceea39bcfaa87f1124cfebd6af4ecb62b886eb189e7b79981b screen-4.4.0.tar.gz"
+md5sums="a32105a91359afab1a4349209a028e31 screen-4.5.0.tar.gz"
+sha256sums="01c3a7c362185f35d6a95dff52d64337076496acd034d717de3c263500cfefb0 screen-4.5.0.tar.gz"
+sha512sums="b2705ed9604355d4153d7902f820af6131a1f2387650f5c6efeda7acf543aad48e8603c26d7c6e74213c8eece994d5d9bb0d114bc19c8d8f3d8e99c00ea4a484 screen-4.5.0.tar.gz"
diff --git a/main/screen/CVE-2015-6806.patch b/main/screen/CVE-2015-6806.patch
deleted file mode 100644
index 24a013b8eb..0000000000
--- a/main/screen/CVE-2015-6806.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Origin: commit b7484c224738247b510ed0d268cd577076958f1b
-Author: Kuang-che Wu <kcwu@csie.org>
-Bug: https://savannah.gnu.org/bugs/?45713
-Bug-Debian: http://bugs.debian.org/797624
-Description: Fix stack overflow due to too deep recursion
- How to reproduce:
- Run this command inside screen
- $ printf '\x1b[10000000T'
- .
- screen will recursively call MScrollV to depth n/256.
- This is time consuming and will overflow stack if n is huge.
-
-diff --git a/ansi.c b/ansi.c
-index a342fb1..152d2ef 100644
---- a/ansi.c
-+++ b/ansi.c
-@@ -2502,13 +2502,13 @@ int n, ys, ye, bce;
- return;
- if (n > 0)
- {
-+ if (ye - ys + 1 < n)
-+ n = ye - ys + 1;
- if (n > 256)
- {
- MScrollV(p, n - 256, ys, ye, bce);
- n = 256;
- }
-- if (ye - ys + 1 < n)
-- n = ye - ys + 1;
- #ifdef COPY_PASTE
- if (compacthist)
- {
-@@ -2562,14 +2562,14 @@ int n, ys, ye, bce;
- }
- else
- {
-- if (n < -256)
-- {
-- MScrollV(p, n + 256, ys, ye, bce);
-- n = -256;
-- }
- n = -n;
- if (ye - ys + 1 < n)
- n = ye - ys + 1;
-+ if (n > 256)
-+ {
-+ MScrollV(p, - (n - 256), ys, ye, bce);
-+ n = 256;
-+ }
-
- ml = p->w_mlines + ye;
- /* Clear lines */