aboutsummaryrefslogtreecommitdiffstats
path: root/main/sdl2/fix-directfb-renderer.patch
diff options
context:
space:
mode:
authorMichael Hamann <michael@content-space.de>2018-04-03 21:37:39 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-05 00:10:08 +0200
commit95601babdcadaebee368f75e62c21407f944a1ed (patch)
tree5ed246c4927aeb7ad0ebd09c083abbe215533913 /main/sdl2/fix-directfb-renderer.patch
parent8a97cde4de891f1d4455412151f5469396ecce68 (diff)
downloadaports-95601babdcadaebee368f75e62c21407f944a1ed.tar.bz2
aports-95601babdcadaebee368f75e62c21407f944a1ed.tar.xz
main/sdl2: fix DirectFB renderer regression
The update to 2.0.8 broke the build of the DirectFB renderer such that it cannot be used anymore, see https://bugzilla.libsdl.org/show_bug.cgi?id=4123. This fixes the regression by re-inserting the affected line in the configure script. Having a working DirectFB renderer in SDL2 is crucial for postmarketOS as it is used for unlocking full disk encryption and displaying the charging animation on almost all devices, see also postmarketOS/osk-sdl#80.
Diffstat (limited to 'main/sdl2/fix-directfb-renderer.patch')
-rw-r--r--main/sdl2/fix-directfb-renderer.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/sdl2/fix-directfb-renderer.patch b/main/sdl2/fix-directfb-renderer.patch
new file mode 100644
index 0000000000..0a5a79e4fa
--- /dev/null
+++ b/main/sdl2/fix-directfb-renderer.patch
@@ -0,0 +1,31 @@
+The update to 2.0.8 broke the build of the DirectFB renderer such that
+it cannot be used anymore, see
+https://bugzilla.libsdl.org/show_bug.cgi?id=4123. This fixes the
+regression by re-inserting the affected line in the configure script.
+
+diff --git a/configure b/configure
+index 1c7f87e..c5ce9c3 100755
+--- a/configure
++++ b/configure
+@@ -21475,6 +21487,9 @@ fi
+
+ $as_echo "#define SDL_VIDEO_DRIVER_DIRECTFB 1" >>confdefs.h
+
++
++$as_echo "#define SDL_VIDEO_RENDER_DIRECTFB 1" >>confdefs.h
++
+ SOURCES="$SOURCES $srcdir/src/video/directfb/*.c"
+ EXTRA_CFLAGS="$EXTRA_CFLAGS $DIRECTFB_CFLAGS"
+
+diff --git a/configure.in b/configure.in
+index 1c7e793..262885b 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2150,6 +2150,7 @@ AC_HELP_STRING([--enable-directfb-shared], [dynamically load directfb support [[
+ , enable_directfb_shared=yes)
+
+ AC_DEFINE(SDL_VIDEO_DRIVER_DIRECTFB, 1, [ ])
++ AC_DEFINE(SDL_VIDEO_RENDER_DIRECTFB, 1, [ ])
+ SOURCES="$SOURCES $srcdir/src/video/directfb/*.c"
+ EXTRA_CFLAGS="$EXTRA_CFLAGS $DIRECTFB_CFLAGS"
+