aboutsummaryrefslogtreecommitdiffstats
path: root/main/sdl2_mixer
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2016-11-08 12:54:35 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2016-11-15 20:09:45 +0000
commitd316b30b71530ec2ab5272f3f022f8de83be6c5c (patch)
treecd2f6f3420d2ff73be5c4ec1e79dad8ac2d8fd8c /main/sdl2_mixer
parent0b71c8fe8ead361850c95a407a7dcae09de299a6 (diff)
downloadaports-d316b30b71530ec2ab5272f3f022f8de83be6c5c.tar.bz2
aports-d316b30b71530ec2ab5272f3f022f8de83be6c5c.tar.xz
main/sdl2_mixer: improve abuild and fix license
Diffstat (limited to 'main/sdl2_mixer')
-rw-r--r--main/sdl2_mixer/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/main/sdl2_mixer/APKBUILD b/main/sdl2_mixer/APKBUILD
index fcd9ca016c..f2ed0d8539 100644
--- a/main/sdl2_mixer/APKBUILD
+++ b/main/sdl2_mixer/APKBUILD
@@ -2,22 +2,23 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=sdl2_mixer
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
+_pkgname=SDL2_mixer
pkgdesc="A simple multi-channel audio mixer"
url="http://www.libsdl.org/projects/SDL_mixer/"
arch="all"
-license="GPL"
-depends=
+license="zlib"
+depends=""
makedepends="sdl2-dev libvorbis-dev libmikmod-dev
- libmodplug-dev flac-dev linux-headers"
+ libmodplug-dev flac-dev linux-headers"
subpackages="$pkgname-dev"
-source="http://www.libsdl.org/projects/SDL_mixer/release/SDL2_mixer-${pkgver}.tar.gz"
-
-_builddir="$srcdir"/SDL2_mixer-$pkgver
+source="http://www.libsdl.org/projects/SDL_mixer/release/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
update_config_sub || return 1
+
sed -e "/CONFIG_FILE_ETC/s/\/etc\/timidity.cfg/\/etc\/timidity++\/timidity.cfg/" \
-e "/DEFAULT_PATH/s/\/etc\/timidity/\/etc\/timidity++/" \
-e "/DEFAULT_PATH2/s/\/usr\/local\/lib\/timidity/\/usr\/lib\/timidity/" \
@@ -25,7 +26,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,7 +40,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}