aboutsummaryrefslogtreecommitdiffstats
path: root/main/seabios/fix-pie.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-02 17:51:32 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-02 17:51:32 +0200
commit5e15740aac29817bd94fb66d5bb63dcb43005f36 (patch)
treefd950f11bbea4c5e58ca269cbe76fbf7f2abb611 /main/seabios/fix-pie.patch
parente300694525500c8f7949424e4d56eba63e9cedd7 (diff)
downloadaports-5e15740aac29817bd94fb66d5bb63dcb43005f36.tar.bz2
aports-5e15740aac29817bd94fb66d5bb63dcb43005f36.tar.xz
main/seabios: fix gcc6 build
the way to disable gcc6's pie is different from esp patches. update makefile to do the right thing.
Diffstat (limited to 'main/seabios/fix-pie.patch')
-rw-r--r--main/seabios/fix-pie.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/main/seabios/fix-pie.patch b/main/seabios/fix-pie.patch
new file mode 100644
index 0000000000..cb8b676ca4
--- /dev/null
+++ b/main/seabios/fix-pie.patch
@@ -0,0 +1,12 @@
+diff -ru seabios-1.9.2/Makefile seabios-1.9.2.fix/Makefile
+--- seabios-1.9.2/Makefile 2016-03-07 16:19:08.000000000 +0200
++++ seabios-1.9.2.fix/Makefile 2016-11-02 17:50:07.418748334 +0200
+@@ -62,7 +62,7 @@
+ -minline-all-stringops -fomit-frame-pointer \
+ -freg-struct-return -ffreestanding -fno-delete-null-pointer-checks \
+ -ffunction-sections -fdata-sections -fno-common -fno-merge-constants
+-COMMONCFLAGS += $(call cc-option,$(CC),-nopie,)
++COMMONCFLAGS += $(call cc-option,$(CC),-no-pie -fno-pic,)
+ COMMONCFLAGS += $(call cc-option,$(CC),-fno-stack-protector,)
+ COMMONCFLAGS += $(call cc-option,$(CC),-fno-stack-protector-all,)
+ COMMONCFLAGS += $(call cc-option,$(CC),-fstack-check=no,)