aboutsummaryrefslogtreecommitdiffstats
path: root/main/shorewall6/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-06 13:57:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-06 14:00:43 +0000
commit0eb75c46cc856896ec25325e1d0673b673ee639e (patch)
tree89eb416cf172e245260b2c8ce6f21f43f36e6fcb /main/shorewall6/APKBUILD
parentc235d12564297cd356a119bd694624bb85ab23a1 (diff)
downloadaports-0eb75c46cc856896ec25325e1d0673b673ee639e.tar.bz2
aports-0eb75c46cc856896ec25325e1d0673b673ee639e.tar.xz
main/shorewall*: upgrade to 4.5.21.3
fixes #1154
Diffstat (limited to 'main/shorewall6/APKBUILD')
-rw-r--r--main/shorewall6/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/main/shorewall6/APKBUILD b/main/shorewall6/APKBUILD
new file mode 100644
index 0000000000..696f8412ed
--- /dev/null
+++ b/main/shorewall6/APKBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=shorewall6
+pkgver=4.5.21.3
+
+_ver=$pkgver
+case $pkgver in
+*.*.*.*) _ver=${pkgver%.*};;
+esac
+
+pkgrel=0
+pkgdesc="Files for the IPV6 Shorewall Firewall"
+url="http://www.shorewall.net/"
+arch="noarch"
+license="GPL-2"
+depends="shorewall-core perl ip6tables iproute2"
+# coreutils for install -T
+makedepends="coreutils bash"
+replaces=""
+subpackages="$pkgname-doc"
+source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/$pkgname-$pkgver.tar.bz2
+ shorewall6.initd
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall6 || return 1
+ install -m755 "$srcdir"/shorewall6.initd "$pkgdir"/etc/init.d/shorewall6
+}
+
+md5sums="010091b972f58be5f318b75239e632aa shorewall6-4.5.21.3.tar.bz2
+685f7d32ff6ce1251658365e7d7076ee shorewall6.initd"
+sha256sums="2eccf072ffb83733e73697f425cfd832de91ec70cb19231bb9f88a461790c0da shorewall6-4.5.21.3.tar.bz2
+a0c9a30cebee098e05d38626d6124398947d4b6cac15d278b1d383bfcc29bcda shorewall6.initd"
+sha512sums="79421c8d7d81a15ef2f8ebb34baa88d003c469ce1a9d2a04c68abb3c5ccf305acf50c4746f76945ce50fc17470d0a1aaa9ea654440d05bf49b80d5de4f8da2ab shorewall6-4.5.21.3.tar.bz2
+ef7c3fb6080cd8f49ad8fef5221cf9e43701aa5838e30ddba73bc2fe1499bb2487a45d020c6b26bde36366cc9fb87a321955a6b5bfe8f844060f462e2d1bac2b shorewall6.initd"