aboutsummaryrefslogtreecommitdiffstats
path: root/main/spice-protocol
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-10-26 14:43:27 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-10-27 12:47:49 +0000
commit1e35cf5a65a5c828baed67c26995780417e98b7c (patch)
treec3fa2a7413e91c876f5fd45d04a6ea54536ac993 /main/spice-protocol
parentbc02bd3e1de24bd21fb74f1b7c92f80ccffd9a5f (diff)
downloadaports-1e35cf5a65a5c828baed67c26995780417e98b7c.tar.bz2
aports-1e35cf5a65a5c828baed67c26995780417e98b7c.tar.xz
main/spice-protocol: upgrade to 0.12.13; modernize
Diffstat (limited to 'main/spice-protocol')
-rw-r--r--main/spice-protocol/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/main/spice-protocol/APKBUILD b/main/spice-protocol/APKBUILD
index 25d9ccb39c..462e989b93 100644
--- a/main/spice-protocol/APKBUILD
+++ b/main/spice-protocol/APKBUILD
@@ -1,37 +1,39 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-protocol
-pkgver=0.12.12
+pkgver=0.12.13
pkgrel=0
pkgdesc="Spice protocol header files"
url="http://www.spice-space.org/"
arch="noarch"
license="BSD and LGPLv2+"
depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
-subpackages=""
+makedepends=""
source="http://www.spice-space.org/download/releases/$pkgname-$pkgver.tar.bz2
"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
+}
+
+# As of version 0.12.13 the check function exists but checks nothing at all!
+check() {
+ cd "$builddir"
+
+ make check
}
package() {
cd "$builddir"
- make pkgconfigdir=/usr/lib/pkgconfig DESTDIR="$pkgdir" install \
- || return 1
+
+ make pkgconfigdir=/usr/lib/pkgconfig DESTDIR="$pkgdir" install
}
-md5sums="3b2886cceaefc228b7afa12300462abd spice-protocol-0.12.12.tar.bz2"
-sha256sums="17abdc2743b5d44b0f4423b61c44aafe9f2078c27218aeea78c2d02a5c409d03 spice-protocol-0.12.12.tar.bz2"
-sha512sums="66e7a902b3c4a5a778cb91ffd9d324b12d414184146ac834dfb3bd81b4b6b1bb56258d3e1ce240b6f8747e1960fce8f0f6b0ada3617e9f9819be7118195fce6b spice-protocol-0.12.12.tar.bz2"
+sha512sums="55840020a7a538e72bf53d2124a6b1920dd2d567418cf02dc33783ae5c78154d5c832d69f2e6570453c4086194b417d10687884de20365c13657ad7ca7b2ae02 spice-protocol-0.12.13.tar.bz2"