aboutsummaryrefslogtreecommitdiffstats
path: root/main/spl
diff options
context:
space:
mode:
authorBreno Leitao <brenohl@br.ibm.com>2017-01-18 15:28:52 -0500
committerTimo Teräs <timo.teras@iki.fi>2017-01-27 16:50:10 +0200
commita47f5a5c3d879c2e66bc9dd25198d46cc446d28d (patch)
treea44917786164195f2186457c81c68f4d1769a9bc /main/spl
parent0e851600ef891ec5ca09cd02e4a54f14ff29f28a (diff)
downloadaports-a47f5a5c3d879c2e66bc9dd25198d46cc446d28d.tar.bz2
aports-a47f5a5c3d879c2e66bc9dd25198d46cc446d28d.tar.xz
main/spl: Add support for ppc64le
Currently spl does not include ppc64le architecture. I just add support for this new platform. Other than that, spl autoconf files are old, thus, I need to call autoreconf, in order to get more update platforms config.
Diffstat (limited to 'main/spl')
-rw-r--r--main/spl/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/spl/APKBUILD b/main/spl/APKBUILD
index 06edbbdcc1..9117318d0e 100644
--- a/main/spl/APKBUILD
+++ b/main/spl/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.6.5.8
pkgrel=0
pkgdesc="Solaris Porting Layer (userland)"
url="http://zfsonlinux.org"
-arch="x86 x86_64 aarch64"
+arch="x86 x86_64 aarch64 ppc64le"
license="GPL"
depends=""
depends_dev=""
@@ -17,6 +17,14 @@ source="https://github.com/zfsonlinux/zfs/releases/download/zfs-$pkgver/spl-$pkg
builddir="$srcdir"/spl-$pkgver
+prepare() {
+ default_prepare || return 1
+ # Current package version does not contain information about ppc64le on
+ # config.sub.
+ update_config_sub
+ update_config_guess
+}
+
build() {
cd "$builddir"
./configure --prefix=/usr \