aboutsummaryrefslogtreecommitdiffstats
path: root/main/squark/0001-fix-missing-symbols-from-lua-module.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-21 13:37:25 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-11-21 11:40:09 +0000
commitcb8f58514f23fdf935ea6ba237d7fb3a722ed090 (patch)
tree1d6da070839740f9c2d95c8abc384b5a1277d7fd /main/squark/0001-fix-missing-symbols-from-lua-module.patch
parent9eec19ed8149f0dd5cb64c0ab383ae5630c6a790 (diff)
downloadaports-cb8f58514f23fdf935ea6ba237d7fb3a722ed090.tar.bz2
aports-cb8f58514f23fdf935ea6ba237d7fb3a722ed090.tar.xz
main/squark: fix lua module
(cherry picked from commit 1737438dc1b51a7e8f97da50164bc3e2849a3774)
Diffstat (limited to 'main/squark/0001-fix-missing-symbols-from-lua-module.patch')
-rw-r--r--main/squark/0001-fix-missing-symbols-from-lua-module.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/squark/0001-fix-missing-symbols-from-lua-module.patch b/main/squark/0001-fix-missing-symbols-from-lua-module.patch
new file mode 100644
index 0000000000..82b046cae3
--- /dev/null
+++ b/main/squark/0001-fix-missing-symbols-from-lua-module.patch
@@ -0,0 +1,25 @@
+From bd36f7e1710fd429c80ef1814beb81db909c177d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 21 Nov 2014 12:02:46 +0200
+Subject: [PATCH] fix missing symbols from lua module
+
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 8814b15..f8acd32 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -7,7 +7,7 @@ common-objs += filterdb.o authdb.o blob.o addr.o config.o reporting.o
+ squark-filter-objs += squark-filter.o $(common-objs)
+ squark-auth-snmp-objs += squark-auth-snmp.o $(common-objs)
+ squark-auth-ip-objs += squark-auth-ip.o $(common-objs)
+-squarkdb.so-objs += lua-squarkdb.o filterdb.o blob.o
++squarkdb.so-objs += lua-squarkdb.o filterdb.o blob.o reporting.o
+
+ CFLAGS_config.o += -DSQUARK_VERSION=\"$(FULL_VERSION)\" \
+ -DCONFDIR=\"$(CONFDIR)\" \
+--
+2.1.3
+