aboutsummaryrefslogtreecommitdiffstats
path: root/main/squashfs-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-07-10 13:16:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-10 13:16:57 +0000
commit6caff47f16141f7a82ec023ce8eb3be64f54c7e0 (patch)
tree688a026e66ef83a003041f2e881ccb97d917c10c /main/squashfs-tools
parentdd5997d778ab12541a432670cac1c5afdc0a7ff7 (diff)
downloadaports-6caff47f16141f7a82ec023ce8eb3be64f54c7e0.tar.bz2
aports-6caff47f16141f7a82ec023ce8eb3be64f54c7e0.tar.xz
main/squashfs-tools: upgrade to 4.3
Diffstat (limited to 'main/squashfs-tools')
-rw-r--r--main/squashfs-tools/APKBUILD19
-rw-r--r--main/squashfs-tools/fix-compat.patch54
2 files changed, 42 insertions, 31 deletions
diff --git a/main/squashfs-tools/APKBUILD b/main/squashfs-tools/APKBUILD
index e2de2d3de7..eb090928cc 100644
--- a/main/squashfs-tools/APKBUILD
+++ b/main/squashfs-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=squashfs-tools
-pkgver=4.2
-pkgrel=2
+pkgver=4.3
+pkgrel=0
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="http://squashfs.sourceforge.net"
arch="all"
@@ -9,7 +9,8 @@ license="GPL"
depends=
makedepends="zlib-dev xz-dev lzo-dev attr-dev"
source="http://downloads.sourceforge.net/sourceforge/squashfs/squashfs$pkgver.tar.gz
- fix-compat.patch"
+ fix-compat.patch
+"
_builddir="$srcdir/squashfs$pkgver/$pkgname"
@@ -32,9 +33,9 @@ package() {
mkdir -p "$pkgdir"/sbin
cp -a mksquashfs unsquashfs "$pkgdir"/sbin
}
-md5sums="1b7a781fb4cf8938842279bd3e8ee852 squashfs4.2.tar.gz
-da3de5c99f6ef34f83a88a066447eac0 fix-compat.patch"
-sha256sums="d9e0195aa922dbb665ed322b9aaa96e04a476ee650f39bbeadb0d00b24022e96 squashfs4.2.tar.gz
-1b10b07691253a97dba93d6a80220b59d2a4be21e306e3ea91265690570a4ed2 fix-compat.patch"
-sha512sums="4b69c5d3008803347d0ce7628957e3873c9ebd799662b25dfb739afb6a1ce97bdd02b0465ac4d949bc38af2155880ac068209dc638b94e5c86a8011ec3a00de0 squashfs4.2.tar.gz
-9532d29e06a691c0628cff21bb4a361d5e6f888adbeef150f52ab65f20678e3ada0a60489d73eba6f0ca8b3eab4c18baf87c6d24c23da0cf81afacf940d1eb91 fix-compat.patch"
+md5sums="d92ab59aabf5173f2a59089531e30dbf squashfs4.3.tar.gz
+1bb2bed6830d32b76f1ca1b6c0349fcd fix-compat.patch"
+sha256sums="0d605512437b1eb800b4736791559295ee5f60177e102e4d4ccd0ee241a5f3f6 squashfs4.3.tar.gz
+249d10b4df7921fae5e0ab4c1f44f3346229f16851240d61a24e85006ed886e6 fix-compat.patch"
+sha512sums="854ed7acc99920f24ecf11e0da807e5a2a162eeda55db971aba63a03f0da2c13b20ec0564a906c4b0e415bd8258b273a10208c7abc0704f2ceea773aa6148a79 squashfs4.3.tar.gz
+868e3923f98a7f8bb980fe8ab0d648e9ae9a55e324bea3830d6047aa348a4302dcb96d65bf59c6e04665891d822e18fad367a37c6704505b8492f64d749fc140 fix-compat.patch"
diff --git a/main/squashfs-tools/fix-compat.patch b/main/squashfs-tools/fix-compat.patch
index 2ecb17176f..2a3b33ca9f 100644
--- a/main/squashfs-tools/fix-compat.patch
+++ b/main/squashfs-tools/fix-compat.patch
@@ -1,36 +1,46 @@
---- squashfs4.2.orig/squashfs-tools/mksquashfs.c
-+++ squashfs4.2/squashfs-tools/mksquashfs.c
-@@ -60,6 +60,10 @@
- #include <sys/sysinfo.h>
- #endif
+--- squashfs4.3.orig/squashfs-tools/action.c
++++ squashfs4.3/squashfs-tools/action.c
+@@ -1905,6 +1905,9 @@
+ return 1;
+ }
-+#if !defined(FNM_EXTMATCH)
++#ifndef FNM_EXTMATCH
++#define FNM_EXTMATCH 0
++#endif
+
+ TEST_FN(name, ACTION_ALL_LNK, \
+ return fnmatch(atom->argv[0], action_data->name,
+--- squashfs4.3.orig/squashfs-tools/mksquashfs.c
++++ squashfs4.3/squashfs-tools/mksquashfs.c
+@@ -4391,6 +4391,9 @@
+ return paths;
+ }
+
++#ifndef FNM_EXTMATCH
+#define FNM_EXTMATCH 0
+#endif
-+
- #ifdef SQUASHFS_TRACE
- #define TRACE(s, args...) \
- do { \
---- squashfs4.2.orig/squashfs-tools/pseudo.c
-+++ squashfs4.2/squashfs-tools/pseudo.c
+
+ int excluded_match(char *name, struct pathname *path, struct pathnames **new)
+ {
+--- squashfs4.3.orig/squashfs-tools/pseudo.c
++++ squashfs4.3/squashfs-tools/pseudo.c
@@ -32,6 +32,7 @@
#include <stdlib.h>
#include <sys/types.h>
#include <sys/wait.h>
+#include <sys/stat.h>
+ #include <ctype.h>
#include "pseudo.h"
-
---- squashfs4.2.orig/squashfs-tools/unsquashfs.c
-+++ squashfs4.2/squashfs-tools/unsquashfs.c
-@@ -32,6 +32,10 @@
- #include <sys/sysinfo.h>
- #include <sys/types.h>
+--- squashfs4.3.orig/squashfs-tools/unsquashfs.c
++++ squashfs4.3/squashfs-tools/unsquashfs.c
+@@ -1410,6 +1410,9 @@
+ free(paths);
+ }
+#ifndef FNM_EXTMATCH
+#define FNM_EXTMATCH 0
+#endif
-+
- struct cache *fragment_cache, *data_cache;
- struct queue *to_reader, *to_deflate, *to_writer, *from_writer;
- pthread_t *thread, *deflator_thread;
+
+ int matches(struct pathnames *paths, char *name, struct pathnames **new)
+ {