aboutsummaryrefslogtreecommitdiffstats
path: root/main/syslinux/APKBUILD
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2019-06-08 16:08:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-10 09:21:58 +0000
commit0ab839af36e71914fb2da45786aa2d88fbe033cf (patch)
treef6adc2209da2836955b339c5c48d860d5b89ad70 /main/syslinux/APKBUILD
parentc0d166d5b136bc5aca00381cd0d30c180f0c888b (diff)
downloadaports-0ab839af36e71914fb2da45786aa2d88fbe033cf.tar.bz2
aports-0ab839af36e71914fb2da45786aa2d88fbe033cf.tar.xz
main/syslinux: Apply Debian's patch to fix HDT.
With the current GCC 8.2.0 from Debian, a section of code calling pow() in zzjson_parse.c is turned into a sequence calling exp(). Since no exp() implementation is available in syslinux those optimizations need to be disabled. Closes #10546
Diffstat (limited to 'main/syslinux/APKBUILD')
-rw-r--r--main/syslinux/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/syslinux/APKBUILD b/main/syslinux/APKBUILD
index c6ada9b092..06806bf17a 100644
--- a/main/syslinux/APKBUILD
+++ b/main/syslinux/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syslinux
pkgver=6.04_pre1
-pkgrel=2
+pkgrel=3
_ver=${pkgver/_/-}
pkgdesc="Boot loader for the Linux operating system"
url="http://syslinux.org"
@@ -17,6 +17,7 @@ ldpath="/usr/share/syslinux"
source="https://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/${pkgver%_pre*}/syslinux-$_ver.tar.xz
update-extlinux.conf
update-extlinux
+ 0018-prevent-pow-optimization.patch
"
subpackages="$pkgname-doc $pkgname-dev"
@@ -57,4 +58,5 @@ package() {
sha512sums="7927dd39be8e2dcf4138a6fea33def67d19d938379d694f15b48fdd2f5924c028b7a9e7bd71d0c7c6630c203e9e2a54296628e530632ad5e6f55b1ebefe8fc98 syslinux-6.04-pre1.tar.xz
c3ff809f9cd60aa8a837d9508e6fcd08204b03cd8a9df86ab42fc6a8fe68784416b359b46378fb0a8f4163bbcbe444957e0e5751c30ff4631d4677eaa94874f4 update-extlinux.conf
-bfeb911507c079c8b01027a7823e562d81100b1fcd0786c707ad33c5ce18fa0eb6d6db34bc7b6cbbc419248188970cebe8286345f4aa3662d16644c51f50b98c update-extlinux"
+bfeb911507c079c8b01027a7823e562d81100b1fcd0786c707ad33c5ce18fa0eb6d6db34bc7b6cbbc419248188970cebe8286345f4aa3662d16644c51f50b98c update-extlinux
+92fa48133ef702092d7acafae0e0e20f9355cd2b5fe199b96fcccba5a1e688c360de4d069391815255f5493228ad03998d20b99748323396d20d12a1f27c60cd 0018-prevent-pow-optimization.patch"