aboutsummaryrefslogtreecommitdiffstats
path: root/main/talloc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-30 12:44:53 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-30 12:45:22 +0000
commit847cb13cff14c0d843794b6c2fa88ef80c1e7c7a (patch)
treeaca40441f35c1fcde116e05779309de2e2b34ea3 /main/talloc
parent699fab80781e1b543a9a33aaf6141c1f98cf1ddc (diff)
downloadaports-847cb13cff14c0d843794b6c2fa88ef80c1e7c7a.tar.bz2
aports-847cb13cff14c0d843794b6c2fa88ef80c1e7c7a.tar.xz
main/talloc: upgrade to 2.1.0, and fix musl build
Diffstat (limited to 'main/talloc')
-rw-r--r--main/talloc/APKBUILD19
-rw-r--r--main/talloc/fix-libreplace.patch84
2 files changed, 98 insertions, 5 deletions
diff --git a/main/talloc/APKBUILD b/main/talloc/APKBUILD
index d53483b8c2..2dd8f1f20a 100644
--- a/main/talloc/APKBUILD
+++ b/main/talloc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=talloc
-pkgver=2.0.8
+pkgver=2.1.0
pkgrel=0
pkgdesc="memory pool management library"
url="http://talloc.samba.org/"
@@ -10,11 +10,13 @@ license="LGPL"
depends=
depends_dev=
replaces="samba-common"
-makedepends="$depends_dev python"
+makedepends="$depends_dev gettext-dev"
install=""
subpackages="$pkgname-dev"
source="http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz
- always-libs.patch"
+ always-libs.patch
+ fix-libreplace.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -44,5 +46,12 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="7857200b58a8617ca18fe2c91296cd93 talloc-2.0.8.tar.gz
-10304afbc3b00346238bf5a969227c68 always-libs.patch"
+md5sums="85a69bfb5808fcadf378bd9eadb1f9c2 talloc-2.1.0.tar.gz
+10304afbc3b00346238bf5a969227c68 always-libs.patch
+b8c06c1a37bce8a7feea3b6896483da0 fix-libreplace.patch"
+sha256sums="0701393882647f823503e3aa075bc67d75c194b376822377dae2d20f9130f08f talloc-2.1.0.tar.gz
+a0b3778ed751f9acb7a7e3cdd13d4f38762f497b35ce761359cc48d366f43318 always-libs.patch
+13617f691c648b44867c1a76d8be7c185021e8a8f3b695f8689a9f6244e65827 fix-libreplace.patch"
+sha512sums="7bdc448c91211299edf16502d263362ac660d5123d8ea7bb2ed58af2231537e4f29da5384b8d5be10254a02b193520890e95a73d697c40eba09728a9b6d56d57 talloc-2.1.0.tar.gz
+dc7ce3fa5152c2e796b184bf2f7937f3424b9f1fece580195364d416ede47e655c04f1fa3ce33cd2a27d0764039ddbaec8d72c4bf3e96f6eac2c09743bed4b8c always-libs.patch
+4adbbeb75de6c55199e10f284e741ee252f403b7809251caf4baf378669770be01d469b23e12f8119ed5dca5080dd45bda1b5b78cc7a791be44c1eb6fb8c0fa2 fix-libreplace.patch"
diff --git a/main/talloc/fix-libreplace.patch b/main/talloc/fix-libreplace.patch
new file mode 100644
index 0000000000..cfe24757ec
--- /dev/null
+++ b/main/talloc/fix-libreplace.patch
@@ -0,0 +1,84 @@
+--- talloc-2.1.0.orig/lib/replace/replace.c
++++ talloc-2.1.0/lib/replace/replace.c
+@@ -508,28 +508,6 @@
+ # error "You need a strtoll function"
+ #endif
+ }
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#ifdef HAVE_STRTOQ
+-long long int rep_strtoll(const char *str, char **endptr, int base)
+-{
+- long long int nb = strtoq(str, endptr, base);
+- /* In linux EINVAL is only returned if base is not ok */
+- if (errno == EINVAL) {
+- if (base == 0 || (base >1 && base <37)) {
+- /* Base was ok so it's because we were not
+- * able to make the convertion.
+- * Let's reset errno.
+- */
+- errno = 0;
+- }
+- }
+- return nb;
+-}
+-#else
+-#error "You need the strtoq function"
+-#endif /* HAVE_STRTOQ */
+-#endif /* HAVE_BSD_STRTOLL */
+ #endif /* HAVE_STRTOLL */
+
+
+@@ -546,28 +524,6 @@
+ # error "You need a strtoull function"
+ #endif
+ }
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#ifdef HAVE_STRTOUQ
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
+-{
+- unsigned long long int nb = strtouq(str, endptr, base);
+- /* In linux EINVAL is only returned if base is not ok */
+- if (errno == EINVAL) {
+- if (base == 0 || (base >1 && base <37)) {
+- /* Base was ok so it's because we were not
+- * able to make the convertion.
+- * Let's reset errno.
+- */
+- errno = 0;
+- }
+- }
+- return nb;
+-}
+-#else
+-#error "You need the strtouq function"
+-#endif /* HAVE_STRTOUQ */
+-#endif /* HAVE_BSD_STRTOLL */
+ #endif /* HAVE_STRTOULL */
+
+ #ifndef HAVE_SETENV
+--- talloc-2.1.0.orig/lib/replace/replace.h
++++ talloc-2.1.0/lib/replace/replace.h
+@@ -355,21 +355,11 @@
+ #ifndef HAVE_STRTOLL
+ #define strtoll rep_strtoll
+ long long int rep_strtoll(const char *str, char **endptr, int base);
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#define strtoll rep_strtoll
+-long long int rep_strtoll(const char *str, char **endptr, int base);
+ #endif
+-#endif
+
+ #ifndef HAVE_STRTOULL
+ #define strtoull rep_strtoull
+ unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#else
+-#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
+-#define strtoull rep_strtoull
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#endif
+ #endif
+
+ #ifndef HAVE_FTRUNCATE