aboutsummaryrefslogtreecommitdiffstats
path: root/main/talloc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-09 13:01:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-09 13:01:56 +0000
commit880a1fd0536939643f9bf3d9dfafc78a80e84c96 (patch)
treef11dbf7cfa082c5b453447a35d158f9dd6fb1042 /main/talloc
parent0b4ff7133b9791ab965d2db94a1bad92dc0ad162 (diff)
downloadaports-880a1fd0536939643f9bf3d9dfafc78a80e84c96.tar.bz2
aports-880a1fd0536939643f9bf3d9dfafc78a80e84c96.tar.xz
main/talloc: upgrade to 2.1.5
Diffstat (limited to 'main/talloc')
-rw-r--r--main/talloc/APKBUILD18
-rw-r--r--main/talloc/fix-libreplace.patch55
2 files changed, 7 insertions, 66 deletions
diff --git a/main/talloc/APKBUILD b/main/talloc/APKBUILD
index bd0b6440fc..7231837591 100644
--- a/main/talloc/APKBUILD
+++ b/main/talloc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=talloc
-pkgver=2.1.3
+pkgver=2.1.5
pkgrel=0
pkgdesc="A memory pool management library"
url="http://talloc.samba.org/"
@@ -15,7 +15,6 @@ install=""
subpackages="$pkgname-dev py-$pkgname:_py"
source="http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz
always-libs.patch
- fix-libreplace.patch
"
_builddir="${srcdir}/${pkgname}-${pkgver}"
@@ -61,12 +60,9 @@ _py() {
"$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="3e285de2228ae67ff0a0f5cec658f627 talloc-2.1.3.tar.gz
-10304afbc3b00346238bf5a969227c68 always-libs.patch
-f4d7a813003048db39160daa0d232b92 fix-libreplace.patch"
-sha256sums="7aa5f75b22d4ef9c737b25515f2a2837ddc13014ff4ac6e58dd9e311f41f2cb0 talloc-2.1.3.tar.gz
-a0b3778ed751f9acb7a7e3cdd13d4f38762f497b35ce761359cc48d366f43318 always-libs.patch
-a5575ca417fa5d13feb7c52429e1a9f618c0b8640462ba780777be5000499b87 fix-libreplace.patch"
-sha512sums="4ec350ab5d7e53c8ae816a3d722b10cce75552f1b3d6a31cc7aae13d6c5722d39a126702c8ebb4fa2f6b7908a6501e916e341e2b660080a6c8d22f70171862f6 talloc-2.1.3.tar.gz
-dc7ce3fa5152c2e796b184bf2f7937f3424b9f1fece580195364d416ede47e655c04f1fa3ce33cd2a27d0764039ddbaec8d72c4bf3e96f6eac2c09743bed4b8c always-libs.patch
-9035bfe86b95b11e1a2cfc5a2950b72916faf721667bf813fa7fad482e815ce57cb1cd94504df0e30a0e699a0afe921e6e564d4d284dac6e446f947d63235793 fix-libreplace.patch"
+md5sums="f497cb42b3d9622b721b72146f1fa3be talloc-2.1.5.tar.gz
+10304afbc3b00346238bf5a969227c68 always-libs.patch"
+sha256sums="3833e750cf0b8c3439186cba38800cba9e26adfbce10ee98ba709c24eb1cdddd talloc-2.1.5.tar.gz
+a0b3778ed751f9acb7a7e3cdd13d4f38762f497b35ce761359cc48d366f43318 always-libs.patch"
+sha512sums="b938d67fcf4c6618f1149b4ec665957a604e3b07ee26e96ed36d94312db8f56b50498f69f9a07782f7f10a25047604e32b0d1786e1051d5f36b696c2755f8741 talloc-2.1.5.tar.gz
+dc7ce3fa5152c2e796b184bf2f7937f3424b9f1fece580195364d416ede47e655c04f1fa3ce33cd2a27d0764039ddbaec8d72c4bf3e96f6eac2c09743bed4b8c always-libs.patch"
diff --git a/main/talloc/fix-libreplace.patch b/main/talloc/fix-libreplace.patch
deleted file mode 100644
index e922be0f1a..0000000000
--- a/main/talloc/fix-libreplace.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- talloc-2.1.0.orig/lib/replace/replace.c
-+++ talloc-2.1.0/lib/replace/replace.c
-@@ -546,28 +524,6 @@
- # error "You need a strtoull function"
- #endif
- }
--#else
--#ifdef HAVE_BSD_STRTOLL
--#ifdef HAVE_STRTOUQ
--unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
--{
-- unsigned long long int nb = strtouq(str, endptr, base);
-- /* In linux EINVAL is only returned if base is not ok */
-- if (errno == EINVAL) {
-- if (base == 0 || (base >1 && base <37)) {
-- /* Base was ok so it's because we were not
-- * able to make the convertion.
-- * Let's reset errno.
-- */
-- errno = 0;
-- }
-- }
-- return nb;
--}
--#else
--#error "You need the strtouq function"
--#endif /* HAVE_STRTOUQ */
--#endif /* HAVE_BSD_STRTOLL */
- #endif /* HAVE_STRTOULL */
-
- #ifndef HAVE_SETENV
---- talloc-2.1.0.orig/lib/replace/replace.h
-+++ talloc-2.1.0/lib/replace/replace.h
-@@ -355,21 +355,11 @@
- #ifndef HAVE_STRTOLL
- #define strtoll rep_strtoll
- long long int rep_strtoll(const char *str, char **endptr, int base);
--#else
--#ifdef HAVE_BSD_STRTOLL
--#define strtoll rep_strtoll
--long long int rep_strtoll(const char *str, char **endptr, int base);
- #endif
--#endif
-
- #ifndef HAVE_STRTOULL
- #define strtoull rep_strtoull
- unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
--#else
--#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
--#define strtoull rep_strtoull
--unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
--#endif
- #endif
-
- #ifndef HAVE_FTRUNCATE