aboutsummaryrefslogtreecommitdiffstats
path: root/main/talloc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-10 08:50:09 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-10 11:26:59 +0200
commitd51c3aadac8805f49e4e8baecc7d71b385c48e5e (patch)
tree724a49a4c9df036930c811da64820696f6213a53 /main/talloc
parent784ae13097131496f26e9601a0b8ee21c80322d8 (diff)
downloadaports-d51c3aadac8805f49e4e8baecc7d71b385c48e5e.tar.bz2
aports-d51c3aadac8805f49e4e8baecc7d71b385c48e5e.tar.xz
main/talloc: upgrade to 2.1.3
Diffstat (limited to 'main/talloc')
-rw-r--r--main/talloc/APKBUILD14
-rw-r--r--main/talloc/fix-libreplace.patch29
2 files changed, 7 insertions, 36 deletions
diff --git a/main/talloc/APKBUILD b/main/talloc/APKBUILD
index d033b02d57..bd0b6440fc 100644
--- a/main/talloc/APKBUILD
+++ b/main/talloc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=talloc
-pkgver=2.1.2
+pkgver=2.1.3
pkgrel=0
pkgdesc="A memory pool management library"
url="http://talloc.samba.org/"
@@ -61,12 +61,12 @@ _py() {
"$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="6bc6e6ac293e739a902dd73cdc88f664 talloc-2.1.2.tar.gz
+md5sums="3e285de2228ae67ff0a0f5cec658f627 talloc-2.1.3.tar.gz
10304afbc3b00346238bf5a969227c68 always-libs.patch
-b8c06c1a37bce8a7feea3b6896483da0 fix-libreplace.patch"
-sha256sums="230d78a3fca75a15ab0f5d76d7bbaeadd3c1e695adcbb085932d227f5c31838d talloc-2.1.2.tar.gz
+f4d7a813003048db39160daa0d232b92 fix-libreplace.patch"
+sha256sums="7aa5f75b22d4ef9c737b25515f2a2837ddc13014ff4ac6e58dd9e311f41f2cb0 talloc-2.1.3.tar.gz
a0b3778ed751f9acb7a7e3cdd13d4f38762f497b35ce761359cc48d366f43318 always-libs.patch
-13617f691c648b44867c1a76d8be7c185021e8a8f3b695f8689a9f6244e65827 fix-libreplace.patch"
-sha512sums="9bb3b8a1be663b63c03ec3336de2e4941052012357dacd0f4303ebb0c4d7f84fb7425bece114fda67167624ea417f57b33dfd5a8f373178c044f8270fecd596a talloc-2.1.2.tar.gz
+a5575ca417fa5d13feb7c52429e1a9f618c0b8640462ba780777be5000499b87 fix-libreplace.patch"
+sha512sums="4ec350ab5d7e53c8ae816a3d722b10cce75552f1b3d6a31cc7aae13d6c5722d39a126702c8ebb4fa2f6b7908a6501e916e341e2b660080a6c8d22f70171862f6 talloc-2.1.3.tar.gz
dc7ce3fa5152c2e796b184bf2f7937f3424b9f1fece580195364d416ede47e655c04f1fa3ce33cd2a27d0764039ddbaec8d72c4bf3e96f6eac2c09743bed4b8c always-libs.patch
-4adbbeb75de6c55199e10f284e741ee252f403b7809251caf4baf378669770be01d469b23e12f8119ed5dca5080dd45bda1b5b78cc7a791be44c1eb6fb8c0fa2 fix-libreplace.patch"
+9035bfe86b95b11e1a2cfc5a2950b72916faf721667bf813fa7fad482e815ce57cb1cd94504df0e30a0e699a0afe921e6e564d4d284dac6e446f947d63235793 fix-libreplace.patch"
diff --git a/main/talloc/fix-libreplace.patch b/main/talloc/fix-libreplace.patch
index cfe24757ec..e922be0f1a 100644
--- a/main/talloc/fix-libreplace.patch
+++ b/main/talloc/fix-libreplace.patch
@@ -1,34 +1,5 @@
--- talloc-2.1.0.orig/lib/replace/replace.c
+++ talloc-2.1.0/lib/replace/replace.c
-@@ -508,28 +508,6 @@
- # error "You need a strtoll function"
- #endif
- }
--#else
--#ifdef HAVE_BSD_STRTOLL
--#ifdef HAVE_STRTOQ
--long long int rep_strtoll(const char *str, char **endptr, int base)
--{
-- long long int nb = strtoq(str, endptr, base);
-- /* In linux EINVAL is only returned if base is not ok */
-- if (errno == EINVAL) {
-- if (base == 0 || (base >1 && base <37)) {
-- /* Base was ok so it's because we were not
-- * able to make the convertion.
-- * Let's reset errno.
-- */
-- errno = 0;
-- }
-- }
-- return nb;
--}
--#else
--#error "You need the strtoq function"
--#endif /* HAVE_STRTOQ */
--#endif /* HAVE_BSD_STRTOLL */
- #endif /* HAVE_STRTOLL */
-
-
@@ -546,28 +524,6 @@
# error "You need a strtoull function"
#endif