aboutsummaryrefslogtreecommitdiffstats
path: root/main/tango-icon-theme
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-03 11:25:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-03 15:08:10 +0000
commitf4be5fabdcf50ac403ff181c57475d7e8e84013d (patch)
tree3b0925637d319952f241f8fa89e3c98759988753 /main/tango-icon-theme
parent8bc9d25fd4351fe8bda82b8fc665fd9c3f15e326 (diff)
downloadaports-f4be5fabdcf50ac403ff181c57475d7e8e84013d.tar.bz2
aports-f4be5fabdcf50ac403ff181c57475d7e8e84013d.tar.xz
main/tango-icon-theme: modernize and add check
Diffstat (limited to 'main/tango-icon-theme')
-rw-r--r--main/tango-icon-theme/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/main/tango-icon-theme/APKBUILD b/main/tango-icon-theme/APKBUILD
index 4a686ba015..76e1242d40 100644
--- a/main/tango-icon-theme/APKBUILD
+++ b/main/tango-icon-theme/APKBUILD
@@ -1,31 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tango-icon-theme
pkgver=0.8.90
-pkgrel=3
+pkgrel=4
pkgdesc="The Tango Desktop Project exists to create a consistent user experience"
url="http://tango.freedesktop.org"
arch="all"
license="CCPL-Attribution-ShareAlike-2.5"
-depends=
makedepends="intltool icon-naming-utils imagemagick-dev imagemagick"
source="http://tango.freedesktop.org/releases/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-build () {
- cd "$_builddir"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
install -D COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="0795895d2f20eddcbd2bffe94ed431a6 tango-icon-theme-0.8.90.tar.gz"
-sha256sums="6e98d8032d57d818acc907ec47e6a718851ff251ae7c29aafb868743eb65c88e tango-icon-theme-0.8.90.tar.gz"
+
sha512sums="78b909bfc8b126060f8a320f5465ee6af98533b5229ebe46952469ba9f08796189b1ad8110e0ffa1e5745d083cad292396af887c4f8792595b0b8d2891258a52 tango-icon-theme-0.8.90.tar.gz"