aboutsummaryrefslogtreecommitdiffstats
path: root/main/tar
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-10 11:40:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-10 11:42:00 +0000
commitfe10831952185e8588ebc7e5518b2b6a2016afb6 (patch)
treed7e1fd546594a09a6812ea23d68e8b1c0b4bce86 /main/tar
parentf00e82a95677cff20f87081de25cdce10a9e21ee (diff)
downloadaports-fe10831952185e8588ebc7e5518b2b6a2016afb6.tar.bz2
aports-fe10831952185e8588ebc7e5518b2b6a2016afb6.tar.xz
main/tar: ignore apk-tools extended attributes
Diffstat (limited to 'main/tar')
-rw-r--r--main/tar/APKBUILD30
-rw-r--r--main/tar/ignore-apk-tools-checksums.patch18
2 files changed, 37 insertions, 11 deletions
diff --git a/main/tar/APKBUILD b/main/tar/APKBUILD
index 229d0dd947..be41c1aa99 100644
--- a/main/tar/APKBUILD
+++ b/main/tar/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=tar
pkgver=1.28
-pkgrel=0
+pkgrel=1
pkgdesc="Utility used to store, backup, and transport files"
url="http://www.gnu.org"
arch="all"
@@ -9,18 +9,23 @@ license='GPL'
depends=
install=
makedepends=
-source="ftp://ftp.gnu.org/gnu/tar/$pkgname-$pkgver.tar.xz"
+source="ftp://ftp.gnu.org/gnu/tar/$pkgname-$pkgver.tar.xz
+ ignore-apk-tools-checksums.patch
+ "
subpackages="$pkgname-doc"
+_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- # fix eglibc-2.16+ build issue
- sed -i -e '/gets is a/d' \
- gnu/stdio.in.h || return 1
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure \
--build=$CBUILD \
@@ -32,7 +37,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir/" install
rm -rf "$pkgdir"/usr/lib/charset.alias
@@ -43,6 +48,9 @@ package() {
ln -s /bin/tar "$pkgdir"/usr/bin/tar
}
-md5sums="49b6306167724fe48f419a33a5beb857 tar-1.28.tar.xz"
-sha256sums="64ee8d88ec1b47a0961033493f919d27218c41b580138fd6802327462aff22f2 tar-1.28.tar.xz"
-sha512sums="0e590abb82ef0202a1f659012477c9ff30d035729b7df47c9c8604901fb0bcdd970386dbc9a6256df63cfd7e629617076fea6ce9735213218f69601daa76c486 tar-1.28.tar.xz"
+md5sums="49b6306167724fe48f419a33a5beb857 tar-1.28.tar.xz
+2c4c807811c4ba827f4510dc2a2f8460 ignore-apk-tools-checksums.patch"
+sha256sums="64ee8d88ec1b47a0961033493f919d27218c41b580138fd6802327462aff22f2 tar-1.28.tar.xz
+4f6330e37e0540f8731256a65fd8ff6de475cf9e3ec9d0245b9dd21d7546713d ignore-apk-tools-checksums.patch"
+sha512sums="0e590abb82ef0202a1f659012477c9ff30d035729b7df47c9c8604901fb0bcdd970386dbc9a6256df63cfd7e629617076fea6ce9735213218f69601daa76c486 tar-1.28.tar.xz
+9cde0f1509328bc5fe2cb46642b53c7681c548cf28a2fb83eda7e9374c9c0ad27a0cd55b9c0cc93951def58dafa55ee71cace5493ddcb7966ee94dc5f1099739 ignore-apk-tools-checksums.patch"
diff --git a/main/tar/ignore-apk-tools-checksums.patch b/main/tar/ignore-apk-tools-checksums.patch
new file mode 100644
index 0000000000..c0a6ea3588
--- /dev/null
+++ b/main/tar/ignore-apk-tools-checksums.patch
@@ -0,0 +1,18 @@
+Make GNU tar ignore the apk-tools header fields
+
+This should problably not be upstreamed
+
+--- ./src/xheader.c.orig
++++ ./src/xheader.c
+@@ -1779,7 +1779,10 @@
+ /* We are storing all extended attributes using this rule even if some of them
+ were stored by some previous rule (duplicates) -- we just have to make sure
+ they are restored *only once* during extraction later on. */
+- { "SCHILY.xattr", xattr_coder, xattr_decoder, 0, true },
++ { "SCHILY.xattr", xattr_coder, xattr_decoder, 0, true },
++
++ /* Ignore apk-tools headers */
++ { "APK-TOOLS.", dummy_coder, dummy_decoder, 0, true },
+
+ { NULL, NULL, NULL, 0, false }
+ };