aboutsummaryrefslogtreecommitdiffstats
path: root/main/tiff/tiffsplit-fname-overflow.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-23 09:37:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-23 09:42:24 +0000
commit4fae22ebc20517a01951fbc52d14eab131e66c5b (patch)
tree74643da93076f2145aa77060a3abf8d807ed9973 /main/tiff/tiffsplit-fname-overflow.patch
parent6c830b0725e1936ca196495fcd1dfd89c91fb769 (diff)
downloadaports-4fae22ebc20517a01951fbc52d14eab131e66c5b.tar.bz2
aports-4fae22ebc20517a01951fbc52d14eab131e66c5b.tar.xz
main/tiff: upgrade to 3.9.5
and clean up the APKBUILD
Diffstat (limited to 'main/tiff/tiffsplit-fname-overflow.patch')
-rw-r--r--main/tiff/tiffsplit-fname-overflow.patch19
1 files changed, 0 insertions, 19 deletions
diff --git a/main/tiff/tiffsplit-fname-overflow.patch b/main/tiff/tiffsplit-fname-overflow.patch
deleted file mode 100644
index cc225890ae..0000000000
--- a/main/tiff/tiffsplit-fname-overflow.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- tiff-3.8.2/tools/tiffsplit.c.orig 2005-12-07 04:48:33.000000000 -0500
-+++ tiff-3.8.2/tools/tiffsplit.c 2006-06-01 21:20:25.039944864 -0400
-@@ -61,14 +61,13 @@
- return (-3);
- }
- if (argc > 2)
-- strcpy(fname, argv[2]);
-+ snprintf(fname, sizeof(fname), "%s", argv[2]);
- in = TIFFOpen(argv[1], "r");
- if (in != NULL) {
- do {
- char path[1024+1];
- newfilename();
-- strcpy(path, fname);
-- strcat(path, ".tif");
-+ snprintf(path, sizeof(path), "%s.tif", fname);
- out = TIFFOpen(path, TIFFIsBigEndian(in)?"wb":"wl");
- if (out == NULL)
- return (-2);