aboutsummaryrefslogtreecommitdiffstats
path: root/main/tinyproxy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-13 06:23:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-13 06:23:26 +0000
commit830c037b3a71c59ed94c60f7b125c54e58707db2 (patch)
tree0e5d8de6d575053df1271af6e22b02978ab71da7 /main/tinyproxy
parent6d6603280b79cac5befb933b9c7da2e5bc380e01 (diff)
downloadaports-830c037b3a71c59ed94c60f7b125c54e58707db2.tar.bz2
aports-830c037b3a71c59ed94c60f7b125c54e58707db2.tar.xz
main/tinyproxy: upgrade to 1.8.4
Diffstat (limited to 'main/tinyproxy')
-rw-r--r--main/tinyproxy/APKBUILD17
-rw-r--r--main/tinyproxy/limit_headers.patch46
2 files changed, 6 insertions, 57 deletions
diff --git a/main/tinyproxy/APKBUILD b/main/tinyproxy/APKBUILD
index 0ef56cbe3b..5e4877ec96 100644
--- a/main/tinyproxy/APKBUILD
+++ b/main/tinyproxy/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=tinyproxy
-pkgver=1.8.3
-pkgrel=5
+pkgver=1.8.4
+pkgrel=0
pkgdesc="Lightweight HTTP proxy"
pkgusers="tinyproxy"
pkggroups="tinyproxy"
@@ -13,15 +13,13 @@ depends=
makedepends="asciidoc"
install="tinyproxy.pre-install"
subpackages="$pkgname-doc"
-source="https://www.banu.com/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
- limit_headers.patch
+source="https://www.samba.org/~obnox/tinyproxy/release/$pkgver/tinyproxy-$pkgver.tar.xz
tinyproxy.initd
"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
- update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -56,12 +54,9 @@ package() {
install -Dm755 "$srcdir"/tinyproxy.initd "$pkgdir"/etc/init.d/tinyproxy
}
-md5sums="292ac51da8ad6ae883d4ebf56908400d tinyproxy-1.8.3.tar.bz2
-cf72d2503f6415079c4702853d467ea8 limit_headers.patch
+md5sums="7d3378ad9681be3423c491775f7d9e35 tinyproxy-1.8.4.tar.xz
9c6df6fa8eb85558e46cf66b96820807 tinyproxy.initd"
-sha256sums="be559b54eb4772a703ad35239d1cb59d32f7cf8a739966742622d57df88b896e tinyproxy-1.8.3.tar.bz2
-b56d6aa51071da6888d30b3b842afa224ac858d740558b37d0af0183985dad5d limit_headers.patch
+sha256sums="3eb89d5adf388690dd170384540d61ca088eb2072d14946184b575810582410a tinyproxy-1.8.4.tar.xz
19e768a03f28b67b61e882441788b2f3af71c4702e8b88e4ad194968c7a5c812 tinyproxy.initd"
-sha512sums="69f1262b39d37f44a42621a0d25985632cdb790c8d9b49335a49a68c0f5237b97b111252856cba119895ac066770645560d2d7cd2de31f02103fa55fb4b3290c tinyproxy-1.8.3.tar.bz2
-6542b72488ad4488db9b6a67d197c11576102ebd168fbd3ebf4f8c6cd18ce550f0cc108517897b7a294539a522ce4d3544964b5c82031a2aa1a8de682378b7ef limit_headers.patch
+sha512sums="4b7ed1657f66c8e26715016c32b1021b39a936632add7c69f1ec624b6f12272b63cd28c50476aa6757a812b8707debbeca5d83c7018599a660a9e5b2de3489e3 tinyproxy-1.8.4.tar.xz
7b63dcc2369bba23cb65d9913af78ec0b26437874bf33dabeba5728755c224d3fc612802ab354ecd0d757faa679ce3545fc5d5413c64ddeab60313f4c7d139a2 tinyproxy.initd"
diff --git a/main/tinyproxy/limit_headers.patch b/main/tinyproxy/limit_headers.patch
deleted file mode 100644
index 1e3e7fb32b..0000000000
--- a/main/tinyproxy/limit_headers.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/src/reqs.c b/src/reqs.c
-index 2e13f48..ce46bf3 100644
---- a/src/reqs.c
-+++ b/src/reqs.c
-@@ -641,6 +641,11 @@ add_header_to_connection (hashmap_t hashofheaders, char *header, size_t len)
- return hashmap_insert (hashofheaders, header, sep, len);
- }
-
-+/* define max number of headers. big enough to handle legitimate cases,
-+ * but limited to avoid DoS
-+ */
-+#define MAX_HEADERS 10000
-+
- /*
- * Read all the headers from the stream
- */
-@@ -648,6 +653,7 @@ static int get_all_headers (int fd, hashmap_t hashofheaders)
- {
- char *line = NULL;
- char *header = NULL;
-+ int count;
- char *tmp;
- ssize_t linelen;
- ssize_t len = 0;
-@@ -656,7 +662,7 @@ static int get_all_headers (int fd, hashmap_t hashofheaders)
- assert (fd >= 0);
- assert (hashofheaders != NULL);
-
-- for (;;) {
-+ for (count = 0; count < MAX_HEADERS; count++) {
- if ((linelen = readline (fd, &line)) <= 0) {
- safefree (header);
- safefree (line);
-@@ -722,6 +728,12 @@ static int get_all_headers (int fd, hashmap_t hashofheaders)
-
- safefree (line);
- }
-+
-+ /* if we get there, this is we reached MAX_HEADERS count.
-+ bail out with error */
-+ safefree (header);
-+ safefree (line);
-+ return -1;
- }
-
- /*