aboutsummaryrefslogtreecommitdiffstats
path: root/main/twm
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-17 19:58:12 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:54:39 +0000
commit0167e55bb996122cf9a4ebda4e3488f52cdb545f (patch)
tree4a2c681dad81e5e36ed9718fe13613ed721ffd95 /main/twm
parentc6c0100762b3f8e10b37fa9492953384799c8d88 (diff)
downloadaports-0167e55bb996122cf9a4ebda4e3488f52cdb545f.tar.bz2
aports-0167e55bb996122cf9a4ebda4e3488f52cdb545f.tar.xz
main/twm: modernise, mark no tests, take maintainership
Diffstat (limited to 'main/twm')
-rw-r--r--main/twm/APKBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/main/twm/APKBUILD b/main/twm/APKBUILD
index 90b69dff33..762e682fe0 100644
--- a/main/twm/APKBUILD
+++ b/main/twm/APKBUILD
@@ -1,12 +1,13 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
-# Maintainer:
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=twm
pkgver=1.0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Tom's or Tab Window Manager for the X Window System"
url="http://www.x.org"
arch="all"
license="MIT"
+options="!check" # No test suite.
depends=""
depends_dev=""
makedepends="$depends_dev bison util-macros libxext-dev libx11-dev libxt-dev
@@ -15,31 +16,19 @@ install=""
subpackages="$pkgname-doc"
source="http://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --datarootdir=/usr/share \
- || return 1
- make || return 1
+ --datarootdir=/usr/share
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
md5sums="59a6f076cdacb5f6945dac809bcf4906 twm-1.0.9.tar.bz2"