aboutsummaryrefslogtreecommitdiffstats
path: root/main/usbredir/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-10-31 12:22:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-03 11:09:42 +0000
commit5a61fe336186b2bd0997abf4fb89e1832b9e4742 (patch)
tree15f00268c82fb0a0f2572822c7834461bb1d39c0 /main/usbredir/APKBUILD
parentd67f7daec85bde9f0883de0f9f6c09254d95e582 (diff)
downloadaports-5a61fe336186b2bd0997abf4fb89e1832b9e4742.tar.bz2
aports-5a61fe336186b2bd0997abf4fb89e1832b9e4742.tar.xz
main/usbredir: upgrade to 0.7.1
Diffstat (limited to 'main/usbredir/APKBUILD')
-rw-r--r--main/usbredir/APKBUILD50
1 files changed, 14 insertions, 36 deletions
diff --git a/main/usbredir/APKBUILD b/main/usbredir/APKBUILD
index 868238f0c4..8ba5a027ca 100644
--- a/main/usbredir/APKBUILD
+++ b/main/usbredir/APKBUILD
@@ -1,35 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=usbredir
-pkgver=0.7
-pkgrel=2
+pkgver=0.7.1
+pkgrel=0
pkgdesc="USB network redirection protocol libraries"
url="http://spice-space.org/page/UsbRedir"
arch="all"
license="GPL2+ LGPL2+"
-depends=""
depends_dev="libusb-dev"
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-server"
source="http://spice-space.org/download/usbredir/usbredir-$pkgver.tar.bz2
- Initialize-usb_redir_hello_header-to-0-in-usbredirparser_init.patch
- usbredirhost-Add-2798-0001-to-the-do-not-reset-blacklist.patch
- usbredirtestclient-Fix-a-memory-leak.patch
"
-_builddir="$srcdir"/usbredir-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir"/usbredir-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,14 +23,18 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
}
server() {
@@ -54,15 +43,4 @@ server() {
mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
}
-md5sums="bc096f160e4ebb848c3a0f0fbf9500fc usbredir-0.7.tar.bz2
-ad93b58e63ba30c1df2f0fc933eb7d74 Initialize-usb_redir_hello_header-to-0-in-usbredirparser_init.patch
-a56584d5298fb196851ccaa7525c19d2 usbredirhost-Add-2798-0001-to-the-do-not-reset-blacklist.patch
-227300e89ac76ffcc1e15248408a8a73 usbredirtestclient-Fix-a-memory-leak.patch"
-sha256sums="0a63a0712b5dc62be9cca44f97270fea5d1ec1fe7dde0c11dc74a01c8e2006aa usbredir-0.7.tar.bz2
-9c00ec29047575a1875f0128bf4bf4798c459bb98952e468bab73824d03283e9 Initialize-usb_redir_hello_header-to-0-in-usbredirparser_init.patch
-eae2360f95883c8aa87c1e1a92c532dbd05493d863288fdbf90d437de80cf264 usbredirhost-Add-2798-0001-to-the-do-not-reset-blacklist.patch
-dc8c8950f880294cc53373904eb98b0e9ae8cdd802d293bcde007bbe5b4de26a usbredirtestclient-Fix-a-memory-leak.patch"
-sha512sums="f615fc52f195c7159d16b551f6ecd9426f2aad64222f24b964fbd66fbf59498d80d4d5cf851cc1be9ddd27a9d962afa05970e1379f1ef02e8ac304235e82ad4a usbredir-0.7.tar.bz2
-a5b0813a98507b22616341814b997b04a2d0259b75d3a6e39c85d9e85e92a422b29edfbb023749e5dc8a2c680858e6ffc4b3ec5b97c077ab99f57c8bc05c799e Initialize-usb_redir_hello_header-to-0-in-usbredirparser_init.patch
-150ac5c43cf0f353e19da61a9a8abe8400c929fe435f2b6184b1f4cf1998083eda559cce3113e4a493e106036fb69a216652964bf7bef464aa17a84e07105166 usbredirhost-Add-2798-0001-to-the-do-not-reset-blacklist.patch
-3bd98d50571f3682359a15401d46dee9ba9f2727ca94ecf47eae826f438fc9a224627510715d0535a08e35e72f97827162704ecdfe0b06a0cc81f0bbd0d19d33 usbredirtestclient-Fix-a-memory-leak.patch"
+sha512sums="f8d26d59d5a530aa413fabe2402fbbd9662760453c2b4e83d34f2e5287c188114ea870f15ae1bc910297649986315be965f0d23d0a2b7b0cec2f207fc65d7598 usbredir-0.7.1.tar.bz2"