aboutsummaryrefslogtreecommitdiffstats
path: root/main/util-linux
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-27 12:16:38 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-27 12:16:56 +0000
commit1dcf00cb4d27e16697d93a3a14ba5ca7952518ae (patch)
treec0081eb7484f08c8dd7e07a9fc62fc080bcdded2 /main/util-linux
parentf2891b7653cdaae4e478503024f5e4bcaa45395e (diff)
downloadaports-1dcf00cb4d27e16697d93a3a14ba5ca7952518ae.tar.bz2
aports-1dcf00cb4d27e16697d93a3a14ba5ca7952518ae.tar.xz
main/util-linux: fix cross building
Diffstat (limited to 'main/util-linux')
-rw-r--r--main/util-linux/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index c099d261fc..a10294acef 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -30,6 +30,8 @@ subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion:bashcomp
if [ -z "$BOOTSTRAP" ]; then
makedepends_host="$makedepends_host ncurses-dev python-dev"
subpackages="$subpackages py-libmount:_py"
+else
+ _bootstrap_config="--without-python"
fi
makedepends="$makedepends_build $makedepends_host"
replaces="e2fsprogs util-linux-ng"
@@ -55,6 +57,7 @@ build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
+ --with-sysroot=$CBUILDROOT \
--prefix=/usr \
--enable-raw \
--with-ncurses \
@@ -66,6 +69,7 @@ build() {
--disable-last \
--disable-sulogin \
--disable-su \
+ $_bootstrap_config \
|| return 1
make || return 1
}