aboutsummaryrefslogtreecommitdiffstats
path: root/main/util-linux
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-04 12:48:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-04 12:48:39 +0000
commitdeafe204dadeb53e562cfb2449cee688a93a7a6c (patch)
tree8fedf9d39371835e29f11bae660a1645780fe5a1 /main/util-linux
parentd60da5b97dd006c6dddf28669890bb20575f8415 (diff)
downloadaports-deafe204dadeb53e562cfb2449cee688a93a7a6c.tar.bz2
aports-deafe204dadeb53e562cfb2449cee688a93a7a6c.tar.xz
main/util-linux: split out findmnt package
Diffstat (limited to 'main/util-linux')
-rw-r--r--main/util-linux/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index 5ec285b6b5..bccde8e92e 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -8,12 +8,12 @@ case $pkgver in
*.*) _v=$pkgver;;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Random collection of Linux utilities"
url="http://kernel.org/~kzak/util-linux/"
arch="all"
license="GPL2 GPL2+ LGPL2+ BSD Public Domain"
-depends=
+depends="findmnt"
# use GNU sed til bb sed is fixed. Also GNU tar is needed
makedepends="zlib-dev sed ncurses-dev tar autoconf automake libtool python-dev linux-headers"
install=
@@ -22,7 +22,7 @@ source="http://www.kernel.org/pub/linux/utils/util-linux/v${_v}/util-linux-$pkgv
ttydefaults.h
"
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid libmount
- libsmartcols libfdisk sfdisk cfdisk
+ libsmartcols libfdisk sfdisk cfdisk findmnt:_findmnt
mcookie blkid py-libmount:_py"
replaces="e2fsprogs util-linux-ng"
@@ -138,6 +138,13 @@ mcookie() {
mv "$pkgdir"/usr/bin/mcookie "$subpkgdir"/usr/bin/
}
+_findmnt() {
+ pkgdesc="findmnt from util-linux"
+ replaces=""
+ mkdir -p "$subpkgdir"/bin
+ mv "$pkgdir"/bin/findmnt "$subpkgdir"/bin
+}
+
_py() {
pkgdesc="python bindings to libmount"
mkdir -p "$subpkgdir"/usr/lib