aboutsummaryrefslogtreecommitdiffstats
path: root/main/wayland-protocols
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-04 09:59:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-04 13:23:03 +0000
commita3700642f6982d96d1b9435baa0c0447a7501c01 (patch)
tree54dff33bee90005baa1c712f7d7e0b6d72eaf121 /main/wayland-protocols
parent768f1eb89531ef6862f4f00525a5dbe6063b3b99 (diff)
downloadaports-a3700642f6982d96d1b9435baa0c0447a7501c01.tar.bz2
aports-a3700642f6982d96d1b9435baa0c0447a7501c01.tar.xz
main/wayland-protocols: move from community
needed by xorg-server
Diffstat (limited to 'main/wayland-protocols')
-rw-r--r--main/wayland-protocols/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/wayland-protocols/APKBUILD b/main/wayland-protocols/APKBUILD
new file mode 100644
index 0000000000..9432fd7803
--- /dev/null
+++ b/main/wayland-protocols/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=wayland-protocols
+pkgver=1.7
+pkgrel=3
+pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
+url="http://wayland.freedesktop.org"
+arch="noarch"
+license="MIT"
+depends=
+provides="$pkgname-dev"
+makedepends="wayland-dev"
+subpackages=
+options="!check"
+source="https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ make DESTDIR="$pkgdir" \
+ -C "$builddir" install || return 1
+}
+
+sha512sums="291a3226cc538de3b81bdffa5de513b305a946bfc3481e21c254fcc6a023e0cf2ff1869509c7ae193da02460f1d4a3c5cd5f1ca13b2550886acffcc636fb30d2 wayland-protocols-1.7.tar.xz"