aboutsummaryrefslogtreecommitdiffstats
path: root/main/wine
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-19 06:34:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-19 06:34:04 +0000
commit1219b7f68c82c11f4836bb1d7b7c1d316b577404 (patch)
tree3d8c2a1e7f397e586943bf249e9cc209d0701e91 /main/wine
parentbe78f98d726d94bc4bb6ac517d02fe58a40a9c2f (diff)
downloadaports-1219b7f68c82c11f4836bb1d7b7c1d316b577404.tar.bz2
aports-1219b7f68c82c11f4836bb1d7b7c1d316b577404.tar.xz
main/wine: moved from testing
Diffstat (limited to 'main/wine')
-rw-r--r--main/wine/APKBUILD36
-rw-r--r--main/wine/dn_skipname.patch38
2 files changed, 74 insertions, 0 deletions
diff --git a/main/wine/APKBUILD b/main/wine/APKBUILD
new file mode 100644
index 0000000000..99e4a5bd0d
--- /dev/null
+++ b/main/wine/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wine
+pkgver=1.1.44
+pkgrel=0
+pkgdesc="A compatibility layer for running Windows programs"
+url="http://www.winehq.com"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
+ libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison
+ libpng-dev jpeg-dev freetype-dev"
+# lcms
+source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
+ dn_skipname.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/dn_skipname.patch || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-x
+ make depend && make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make prefix="$pkgdir"/usr install || return 1
+ mkdir -p "$pkgdir"/etc/wine
+}
+md5sums="f18649bd71b9099fecad22436d239cba wine-1.1.44.tar.bz2
+6ebeaa64eddf97be3267db236ce84b71 dn_skipname.patch"
diff --git a/main/wine/dn_skipname.patch b/main/wine/dn_skipname.patch
new file mode 100644
index 0000000000..99ecf83158
--- /dev/null
+++ b/main/wine/dn_skipname.patch
@@ -0,0 +1,38 @@
+--- ./dlls/dnsapi/ns_parse.c.orig
++++ ./dlls/dnsapi/ns_parse.c
+@@ -69,6 +69,35 @@
+ } while (0)
+
+ /* Public. */
++#ifdef __UCLIBC__
++int
++dn_skipname(const u_char *comp_dn, const u_char *eom)
++{
++ const u_char *cp;
++ int n;
++
++ cp = comp_dn;
++ while (cp < eom && (n = *cp++)) {
++ /*
++ * check for indirection
++ */
++ switch (n & INDIR_MASK) {
++ case 0: /* normal case, n == len */
++ cp += n;
++ continue;
++ case INDIR_MASK: /* indirection */
++ cp++;
++ break;
++ default: /* illegal type */
++ return (-1);
++ }
++ break;
++ }
++ if (cp > eom)
++ return (-1);
++ return (cp - comp_dn);
++}
++#endif
+
+ static int
+ dns_ns_skiprr(const u_char *ptr, const u_char *eom, ns_sect section, int count) {