aboutsummaryrefslogtreecommitdiffstats
path: root/main/xclip
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-07-12 13:14:46 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-07-12 13:21:40 +0200
commit39f4f6ca361fabf89b5a87f60a07d864d3bd6bba (patch)
tree40d6d85e5654a0a31949e04aca962063be01db79 /main/xclip
parentbaa04a75170112f9713dd5ad72a5732f9bfaeaac (diff)
downloadaports-39f4f6ca361fabf89b5a87f60a07d864d3bd6bba.tar.bz2
aports-39f4f6ca361fabf89b5a87f60a07d864d3bd6bba.tar.xz
main/xclip: move from testing/
The APKBUILD is quite simple and I am not aware of any known issues with this aport so I guess it's time to move it to main. Also change the maintainer since I believe that Orion is no longer actively working on alpine aports.
Diffstat (limited to 'main/xclip')
-rw-r--r--main/xclip/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/main/xclip/APKBUILD b/main/xclip/APKBUILD
new file mode 100644
index 0000000000..ea8d42b588
--- /dev/null
+++ b/main/xclip/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Orion <systmkor@gmail.com>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=xclip
+pkgver=0.12
+pkgrel=3
+pkgdesc="Command line interface to the X11 clipboard"
+url="https://github.com/astrand/xclip"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="autoconf automake libxmu-dev libx11-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/astrand/${pkgname}/archive/${pkgver}.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$builddir"
+ default_prepare || return 1
+ autoreconf -vif || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 README ChangeLog \
+ "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+}
+
+md5sums="5d001eec349fc8299400abea4f2cbb89 xclip-0.12.tar.gz"
+sha256sums="bf62559ffb84acd1362c4e4fe94a7b1125ffb0cce1f3f43ed88da21f32e01e31 xclip-0.12.tar.gz"
+sha512sums="289ab111b4b1e371c32fa66f367422989bb7cce21b9167c49fbd484c8c87d1a1f45266f70830ce4b04e7b8e30fb7eb993e7bd8b85198497ff114f723fcab2c1a xclip-0.12.tar.gz"