aboutsummaryrefslogtreecommitdiffstats
path: root/main/xen/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-08-25 11:01:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-08-25 11:03:34 +0000
commitbcf7b52774f1b0a3e405a207c3c4a5342b951f40 (patch)
tree2c3e2c1c4995fac9cb83d61e8dc755b19833aef5 /main/xen/APKBUILD
parente794f0ffd98383718cfeae36bbee7d473846890b (diff)
downloadaports-bcf7b52774f1b0a3e405a207c3c4a5342b951f40.tar.bz2
aports-bcf7b52774f1b0a3e405a207c3c4a5342b951f40.tar.xz
main/xen: fix hvmloader
hvmloader is 32 bit but pulled in 64bit stdint from musl headers. we solve this by providing our own stdint_local.h elf.h pulls in stdint.h too so we ship our own elf_local.h too ref #3308
Diffstat (limited to 'main/xen/APKBUILD')
-rw-r--r--main/xen/APKBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
index 97d8a16882..88cdd1bad2 100644
--- a/main/xen/APKBUILD
+++ b/main/xen/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xen
pkgver=4.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="Xen hypervisor"
url="http://www.xen.org/"
arch="x86_64"
@@ -39,6 +39,9 @@ source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.g
init-xenstore-domain.patch
musl-support.patch
+ musl-hvmloader-fix-stdint.patch
+ stdint_local.h
+ elf_local.h
xenstored.initd
xenstored.confd
@@ -66,6 +69,10 @@ prepare() {
esac
done
+ # install our stdint_local.h and elf_local.h
+ install "$srcdir"/stdint_local.h "$srcdir"/elf_local.h \
+ "$_builddir"/tools/firmware/ || return 1
+
# remove all -Werror
msg "Eradicating -Werror..."
find . -name '*.mk' -o -name 'Make*' | xargs sed -i -e 's/-Werror//g' \
@@ -214,6 +221,9 @@ e449bb3359b490804ffc7b0ae08d62a0 hotplug-vif-vtrill.patch
229539a822e14a6a62babffd71ecfbf3 0001-ipxe-dont-clobber-ebp.patch
08a30d56902b660f5102a5c208e545c9 init-xenstore-domain.patch
f7aa282a27f270a923f229f2040cd7b5 musl-support.patch
+2b1afbf120b69c5d14c846178378116b musl-hvmloader-fix-stdint.patch
+c9313a790faa727205627a1657b9bf06 stdint_local.h
+c13f954d041a6fa78d0d241ad1780c0b elf_local.h
bd6d294c47d4285e770aefa6e63eeea2 xenstored.initd
d86504e12f05deca6b3eeeb90157160e xenstored.confd
ed262f15fb880badb53575539468646c xenconsoled.initd
@@ -242,6 +252,9 @@ dd1e784bc455eb62cb85b3fa24bfc34f575ceaab9597ef6a2f1ee7ff7b3cae0a hotplug-vif-vt
751ef06569de66578b8713dc170976832b0671ac2696f32eb9ad69d60332d594 0001-ipxe-dont-clobber-ebp.patch
0204d69804e83864cd6b2122f51b9c1940588158a35c159a7ef0c3b8fb0af4cb init-xenstore-domain.patch
2513ab530c80b32bd7fe4d35a5b1ecbda14c8e093e556e040a68226796e63791 musl-support.patch
+09b9feb9ea6f9c1bda5cc1672f42e8fc5186dc9dd5561f28c6f1904d80aca7fa musl-hvmloader-fix-stdint.patch
+6b4ad2a9fdb3e23b06c8c1961a46b06c15a46471fe6fb13cdc269da37466f334 stdint_local.h
+7f1ed2db24d8eba87a08eea0601a9ab339209906fdfa74c8c03564a1a6e6471e elf_local.h
2f3fa767e57c18433d196bb2aecfb575224183193f4acece85971683a9a5411b xenstored.initd
991bb7c9da02941556e29714bd96b26e39e57e0a5b514eadd78d9bfa3fa5a9dc xenstored.confd
93bea2eb90ea1b4628854c8141dd351bbd1fbc5959b12795447ea933ad025f01 xenconsoled.initd
@@ -270,6 +283,9 @@ f095ea373f36381491ad36f0662fb4f53665031973721256b23166e596318581da7cbb0146d0beb2
c3a1b270347a99c8ce21118010ad8d817b4462a31cc5c75352faa7086969ef0646f3f4d0922d85c2e504cff091ce7e9fe79c92f983c2ba4af2fae85c52c3835a 0001-ipxe-dont-clobber-ebp.patch
475eb800660dc928914b8c15562f18f24d6e7a76f4cc7bed9249ce52d444c29aec1aef843eb37ade0c7c9616195bbbc1606a3195e25b2bd4b6a1d1af5f69256e init-xenstore-domain.patch
3d6b180d631c6d7baeff9976503cf6b16f24b0e99c25b2b2a5153db85f41600159d10d4f47eda0e33e1f41197dc9d6d935cf33f31ffbcf429d35002e0affdb2d musl-support.patch
+4acf7e360ae94f7c0f7541fcd106389402f215c28bd18ed1fd4be9d4b9d12550e17152f7e19b19793e16d4ee0e131ec3e3ce6011b42bc7683fcebdb4051c6109 musl-hvmloader-fix-stdint.patch
+9dcb481c5b83c7df23e87be717d8a9234014f26a0f80893e125fe8110e2923562d95162d18ff64c08b5782cd7c085f90378a9e0802b3995c077c8ba32bbb669f stdint_local.h
+853467a2d055c5bfbdc7bdca175a334241be44a7c5ac3c0a84a4bc5463b5c070b66d37e2a557429ef860727a6b7350683af758cc2494d85b6be4d883143a2c0d elf_local.h
7a21f7cc05d5593a96ca5254ffed55919de97d7a1fe0d5b360876a5c0811416c9f985682c5b70325d99166ebabd149d0d061ea58da4283b2b0d2aab0d75e5368 xenstored.initd
093f7fbd43faf0a16a226486a0776bade5dc1681d281c5946a3191c32d74f9699c6bf5d0ab8de9d1195a2461165d1660788e92a3156c9b3c7054d7b2d52d7ff0 xenstored.confd
12f981b2459c65d66e67ec0b32d0d19b95a029bc54c2a79138cfe488d3524a22e51860f755abfe25ddcdaf1b27f2ded59b6e350b9d5f8791193d00e2d3673137 xenconsoled.initd