aboutsummaryrefslogtreecommitdiffstats
path: root/main/xen/xen-blktap2-uclibc.patch
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-02-17 19:06:17 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-17 19:06:17 -0600
commitbd4729f70cc9cd71d9defca1cd0dc82893bf8f10 (patch)
tree0c39c7f0f0dc3e39f1d6a5701b4256d56db51235 /main/xen/xen-blktap2-uclibc.patch
parentf369602f6bfd7345808a67c2427e770e97f44ca5 (diff)
downloadaports-bd4729f70cc9cd71d9defca1cd0dc82893bf8f10.tar.bz2
aports-bd4729f70cc9cd71d9defca1cd0dc82893bf8f10.tar.xz
testing/xen: promote to main
Diffstat (limited to 'main/xen/xen-blktap2-uclibc.patch')
-rw-r--r--main/xen/xen-blktap2-uclibc.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/xen/xen-blktap2-uclibc.patch b/main/xen/xen-blktap2-uclibc.patch
new file mode 100644
index 0000000000..7ce1dc0cfd
--- /dev/null
+++ b/main/xen/xen-blktap2-uclibc.patch
@@ -0,0 +1,22 @@
+--- xen-4.0.1/tools/blktap2/drivers/bswap.h
++++ xen-4.0.1.mod/tools/blktap2/drivers/bswap.h
+@@ -15,6 +15,8 @@
+ #define bswap_64(x) swap64(x)
+ #else
+
++#define HAVE_BYTESWAP_H
++
+ #ifdef HAVE_BYTESWAP_H
+ #include <byteswap.h>
+ #else
+--- xen-4.0.1/tools/blktap2/vhd/lib/Makefile
++++ xen-4.0.1.mod/tools/blktap2/vhd/lib/Makefile
+@@ -23,6 +23,8 @@
+ LIBS := -luuid
+ endif
+
++LIBS += -liconv
++
+ # Get gcc to generate the dependencies for us.
+ CFLAGS += -Wp,-MD,.$(@F).d
+ DEPS = .*.d