aboutsummaryrefslogtreecommitdiffstats
path: root/main/xen
diff options
context:
space:
mode:
authorAndy Chu <andy@oilshell.org>2017-10-16 21:19:46 -0700
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-19 04:41:00 +0000
commit94eec0c787af9a21f974d849af5a50a9e4969369 (patch)
tree80706461b65e086493cbaf2799537f79033b2c28 /main/xen
parent81d586db2b680f8b2631e42e2eca44dd715c84e3 (diff)
downloadaports-94eec0c787af9a21f974d849af5a50a9e4969369.tar.bz2
aports-94eec0c787af9a21f974d849af5a50a9e4969369.tar.xz
main/xen,community/rng-tools: remove unicode whitespace from APKBUILDs
Fix bugs in 2 packages by removing Unicode whitespace. I found these problems by parsing all APKBUILD scripts with my shell (http://www.oilshell.org/). The problem only occurs if 'make' fails. Here is an excerpt: $ od -c unicode-space.sh 0000000 m a k e | | 302 240 r e t u r n 0000020 1 \n 0000022 \302 \204 is a utf-8 whitespace. No shells accept this -- it's parsed as part of the 'return' word, which makes it an invalid command. $ busybox ash unicode-space.sh make: *** No targets specified and no makefile found. Stop. unicode-space.sh: line 1:  return: not found $ bash unicode-space.sh make: *** No targets specified and no makefile found. Stop. unicode-space.sh: line 1:  return: command not found $ dash unicode-space.sh make: *** No targets specified and no makefile found. Stop. unicode-space.sh: 1: unicode-space.sh:  return: not found Remove '|| return 1' from lines that contained unicode whitespace. abuild now runs with 'set -e'.
Diffstat (limited to 'main/xen')
-rw-r--r--main/xen/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
index 754d377101..f5ca2a794a 100644
--- a/main/xen/APKBUILD
+++ b/main/xen/APKBUILD
@@ -260,7 +260,7 @@ build_docs() {
munge_cflags
msg "Building documentation..."
- make docs || return 1
+ make docs
}
build_stubdom() {