aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-qxl/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-06 18:58:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-06 19:00:21 +0000
commitd218d05fda28b536affc543f99ba423ba665c06e (patch)
tree679f8fd61117c6e8644ad0bb8abb17c9dc05e593 /main/xf86-video-qxl/APKBUILD
parent849e18bde39902ccb40259004efd59abe9330bf8 (diff)
downloadaports-d218d05fda28b536affc543f99ba423ba665c06e.tar.bz2
aports-d218d05fda28b536affc543f99ba423ba665c06e.tar.xz
main/xf86-video-qxl: rename spiceqxl to xspice and install the wrapper
we only need to run configure and make once
Diffstat (limited to 'main/xf86-video-qxl/APKBUILD')
-rw-r--r--main/xf86-video-qxl/APKBUILD43
1 files changed, 16 insertions, 27 deletions
diff --git a/main/xf86-video-qxl/APKBUILD b/main/xf86-video-qxl/APKBUILD
index 09d1f7240e..849777df8f 100644
--- a/main/xf86-video-qxl/APKBUILD
+++ b/main/xf86-video-qxl/APKBUILD
@@ -2,19 +2,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-qxl
pkgver=0.1.5
-pkgrel=1
+pkgrel=2
pkgdesc="Xorg X11 qxl video driver"
url="http://www.x.org"
arch="x86 x86_64"
license="MIT"
depends=
makedepends="xorg-server-dev spice-dev xorg-server xproto fontsproto
- randrproto renderproto videoproto xf86dgaproto"
+ randrproto renderproto videoproto xf86dgaproto python2"
install=""
source="http://xorg.freedesktop.org/releases/individual/driver/xf86-video-qxl-$pkgver.tar.bz2"
builddir="$srcdir"/xf86-video-qxl-$pkgver
-subpackages="xf86-video-spiceqxl xf86-video-spiceqxl-doc"
+subpackages="$pkgname-doc xspice"
build() {
cd "$builddir"
@@ -27,36 +27,25 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --enable-xspice=only \
- --disable-kms \
- || return 1
- make || return 1
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --enable-xspice=yes
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-spiceqxl() {
- mkdir -p "$subpkgdir"/usr/lib/xorg/modules/drivers
- cp "$_builddir"/src/.libs/spiceqxl_drv.so "$subpkgdir"/usr/lib/xorg/modules/drivers
+ make DESTDIR="$pkgdir" install
}
-doc() {
- arch="noarch"
- mkdir -p "$subpkgdir"/usr/share/doc/spiceqxl
- cp "$_builddir"/examples/spiceqxl.xorg.conf.example "$subpkgdir"/usr/share/doc/spiceqxl
+xspice() {
+ pkgdesc="X server that can be accessed by a Spice client"
+ depends="python2"
+ mkdir -p "$subpkgdir"/usr/lib/xorg/modules/drivers \
+ "$subpkgdir"/etc/X11
+ mv "$pkgdir"/usr/lib/xorg/modules/drivers/spiceqxl_drv.so \
+ "$subpkgdir"/usr/lib/xorg/modules/drivers/
+ mv "$pkgdir"/usr/bin/ "$subpkgdir"/usr/
+ install -m 644 "$builddir"/examples/spiceqxl.xorg.conf.example \
+ "$subpkgdir"/etc/X11/spiceqxl.xorg.conf
}
sha512sums="7510b2d037b3e978df6063b29e2406f3d1270695a239f29fdaec9b1dc65a30ab10cb959f15eb336f78e93aa708d41c64c5ea43803958feffc64542229605b782 xf86-video-qxl-0.1.5.tar.bz2"