aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-rendition/APKBUILD
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-03-29 14:06:44 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-30 00:12:20 +0000
commit6559182bfc52b1784b0735d528187d2c21cb7f62 (patch)
tree5de22cc18070628d950318c52ec2cfcf16348e7e /main/xf86-video-rendition/APKBUILD
parent305214f6141453341544382cf989d5b91f688261 (diff)
downloadaports-6559182bfc52b1784b0735d528187d2c21cb7f62.tar.bz2
aports-6559182bfc52b1784b0735d528187d2c21cb7f62.tar.xz
main/xf86-video-rendition: Simplify build script
Simplifying build script for xf86-video-rendition, since prepare() is not required on this package, since there is no patches, and, if it was required, I understand that default_prepare() should do the same job as current prepare(), thus removing prepare() section.
Diffstat (limited to 'main/xf86-video-rendition/APKBUILD')
-rw-r--r--main/xf86-video-rendition/APKBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/main/xf86-video-rendition/APKBUILD b/main/xf86-video-rendition/APKBUILD
index 5c4c4ef3b2..7796e673df 100644
--- a/main/xf86-video-rendition/APKBUILD
+++ b/main/xf86-video-rendition/APKBUILD
@@ -13,17 +13,10 @@ makedepends="xorg-server-dev libxi-dev fontsproto randrproto
source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir=$srcdir/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd $builddir
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \