aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-rendition
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-03-17 09:32:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-17 11:01:25 +0000
commit44ef010faacedd7cd5c8eae10807dce23fc3f107 (patch)
treea5f40d68a8f6cda3eac0478f81188840b186981a /main/xf86-video-rendition
parent94dcde212867ffcb3ee91b54fd3dedf51c184a7f (diff)
downloadaports-44ef010faacedd7cd5c8eae10807dce23fc3f107.tar.bz2
aports-44ef010faacedd7cd5c8eae10807dce23fc3f107.tar.xz
main/xf86-video-rendition: rebuild against xorg-server 1.17
Diffstat (limited to 'main/xf86-video-rendition')
-rw-r--r--main/xf86-video-rendition/APKBUILD10
-rw-r--r--main/xf86-video-rendition/git-fixes.patch125
-rw-r--r--main/xf86-video-rendition/mibstore.patch35
3 files changed, 130 insertions, 40 deletions
diff --git a/main/xf86-video-rendition/APKBUILD b/main/xf86-video-rendition/APKBUILD
index c5de6cf3f1..f11b3731ba 100644
--- a/main/xf86-video-rendition/APKBUILD
+++ b/main/xf86-video-rendition/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-rendition
pkgver=4.2.5
-pkgrel=5
+pkgrel=6
pkgdesc="Rendition video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -12,7 +12,7 @@ makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto"
source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
- mibstore.patch"
+ git-fixes.patch"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -42,8 +42,8 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
md5sums="6db439a0f89e6f00c4f5175510d8e0c1 xf86-video-rendition-4.2.5.tar.bz2
-bf6125aff3bcce84b6d289c1b8ae510b mibstore.patch"
+3f1fa36dc881ff41a8fa28ce0ab9069d git-fixes.patch"
sha256sums="39b5569338237de6e17b2a2c6be73ac6c405ee596079c41a7028cfd6e54134cb xf86-video-rendition-4.2.5.tar.bz2
-93a59e9deed98af201c8bb231fdf3214fcd02dae8ef2f880b044b4fd100cdb4c mibstore.patch"
+43301ab296b6a928ed880ea56fc476c7c2d80803c9a63b71e0391fca10457f55 git-fixes.patch"
sha512sums="203529e2a9c917362ac7c9b4247a9a0a4a7e1911bd022a26b00f467ec4cfd9ce742465aba29618cbfaa5ac5ff0b43e5a54f651e45e81aa950776685e4f74ba72 xf86-video-rendition-4.2.5.tar.bz2
-f05cfc55def69453152d2f45d50cadb5641601cd7f7f8a197482a7ea6cfbec271c5872cdfff3fc3c9dea9a878990a4a943685c383095d925e17641a3c4a2acba mibstore.patch"
+a207ec4a6ae086c9a5424485f2001b5a18273c3aedb6ccb347a6d5320cfceb5e4ab159fbc89cc315a707064c0eef8580ec9379b09ad033ce19242cc0ba310f94 git-fixes.patch"
diff --git a/main/xf86-video-rendition/git-fixes.patch b/main/xf86-video-rendition/git-fixes.patch
new file mode 100644
index 0000000000..2dad6aa8ec
--- /dev/null
+++ b/main/xf86-video-rendition/git-fixes.patch
@@ -0,0 +1,125 @@
+From 3a3ee1c45e54a808947cc26ca11f0a5299571053 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:50 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/rendition.c b/src/rendition.c
+index 7c74f76..888bb4a 100644
+--- a/src/rendition.c
++++ b/src/rendition.c
+@@ -1173,7 +1173,6 @@ renditionScreenInit(SCREEN_INIT_ARGS_DECL)
+ fbPictureInit (pScreen, 0, 0);
+
+ xf86SetBlackWhitePixels(pScreen);
+- miInitializeBackingStore(pScreen);
+
+ /*********************************************************/
+ /* The actual setup of the driver-specific code */
+diff --git a/src/rendition.h b/src/rendition.h
+index f7f13d4..297117e 100644
+--- a/src/rendition.h
++++ b/src/rendition.h
+@@ -28,9 +28,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ /* All drivers using the mi colormap manipulation need this */
+ #include "micmap.h"
+
+--
+cgit v0.9.0.2-2-gbebe
+From 30a4b73644ee22904824d4847e44ca69369fad02 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 30 Sep 2014 10:21:58 -0400
+Subject: Fix build against xserver 1.17
+
+Also port from pci_device_map_region to pci_device_map_range. Somewhat
+alarming that the previous code was using map_region but unmap_range...
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+
+diff --git a/src/rendition.c b/src/rendition.c
+index 888bb4a..9677850 100644
+--- a/src/rendition.c
++++ b/src/rendition.c
+@@ -1371,6 +1371,18 @@ renditionMapMem(ScrnInfoPtr pScreenInfo)
+ /* Override on users request */
+ WriteCombine
+ = xf86ReturnOptValBool(pRendition->Options, OPTION_FBWC, WriteCombine);
++#ifdef XSERVER_LIBPCIACCESS
++ mapOption = PCI_DEV_MAP_FLAG_WRITABLE;
++ if (WriteCombine)
++ mapOption |= PCI_DEV_MAP_FLAG_WRITE_COMBINE;
++
++ err = pci_device_map_range(pRendition->PciInfo,
++ pRendition->PciInfo->regions[0].base_addr,
++ pRendition->PciInfo->regions[0].size,
++ mapOption, (void *)&pRendition->board.vmem_base);
++
++ return (err == 0);
++#else
+ if (WriteCombine) {
+ xf86DrvMsg(pScreenInfo->scrnIndex, X_CONFIG,
+ ("Requesting Write-Combined memory access\n"));
+@@ -1381,12 +1393,6 @@ renditionMapMem(ScrnInfoPtr pScreenInfo)
+ mapOption = VIDMEM_MMIO;
+ }
+
+-#ifdef XSERVER_LIBPCIACCESS
+- err = pci_device_map_region(pRendition->PciInfo, 0, TRUE);
+- pRendition->board.vmem_base = pRendition->PciInfo->regions[0].memory;
+-
+- return (err == 0);
+-#else
+ pRendition->board.vmem_base=
+ xf86MapPciMem(pScreenInfo->scrnIndex, mapOption,
+ pRendition->pcitag,
+@@ -1415,7 +1421,7 @@ renditionUnmapMem(ScrnInfoPtr pScreenInfo)
+ #else
+ pci_device_unmap_range(pRendition->PciInfo,
+ pRendition->board.vmem_base,
+- pScreenInfo->videoRam * 1024);
++ pRendition->PciInfo->regions[0].size);
+ #endif
+ return TRUE;
+ #ifdef DEBUG0
+--
+cgit v0.10.2
+From df5646745bf563bb36a0db1796c318fe64bf8efe Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 30 Sep 2014 10:24:18 -0400
+Subject: Remove dependency on xf86PciInfo.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+
+diff --git a/src/rendition.h b/src/rendition.h
+index 297117e..4ef03a7 100644
+--- a/src/rendition.h
++++ b/src/rendition.h
+@@ -14,9 +14,6 @@
+ /* Everything using inb/outb, etc needs "compiler.h" */
+ #include "compiler.h"
+
+-/* Drivers for PCI hardware need this */
+-#include "xf86PciInfo.h"
+-
+ /* Drivers that need to access the PCI config space directly need this */
+ #include "xf86Pci.h"
+
+@@ -66,4 +63,8 @@
+
+ #include "compat-api.h"
+ /* end of __RENDITION_H__ */
++
++#define PCI_CHIP_V1000 0x0001
++#define PCI_CHIP_V2x00 0x2000
++
+ #endif
+--
+cgit v0.10.2
+
diff --git a/main/xf86-video-rendition/mibstore.patch b/main/xf86-video-rendition/mibstore.patch
deleted file mode 100644
index 77c4d34dea..0000000000
--- a/main/xf86-video-rendition/mibstore.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 3a3ee1c45e54a808947cc26ca11f0a5299571053 Mon Sep 17 00:00:00 2001
-From: Adam Jackson <ajax@redhat.com>
-Date: Tue, 25 Sep 2012 12:54:50 +0000
-Subject: Remove mibstore.h
-
-Signed-off-by: Adam Jackson <ajax@redhat.com>
----
-diff --git a/src/rendition.c b/src/rendition.c
-index 7c74f76..888bb4a 100644
---- a/src/rendition.c
-+++ b/src/rendition.c
-@@ -1173,7 +1173,6 @@ renditionScreenInit(SCREEN_INIT_ARGS_DECL)
- fbPictureInit (pScreen, 0, 0);
-
- xf86SetBlackWhitePixels(pScreen);
-- miInitializeBackingStore(pScreen);
-
- /*********************************************************/
- /* The actual setup of the driver-specific code */
-diff --git a/src/rendition.h b/src/rendition.h
-index f7f13d4..297117e 100644
---- a/src/rendition.h
-+++ b/src/rendition.h
-@@ -28,9 +28,6 @@
- /* All drivers initialising the SW cursor need this */
- #include "mipointer.h"
-
--/* All drivers implementing backing store need this */
--#include "mibstore.h"
--
- /* All drivers using the mi colormap manipulation need this */
- #include "micmap.h"
-
---
-cgit v0.9.0.2-2-gbebe