aboutsummaryrefslogtreecommitdiffstats
path: root/main/xhost
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-12 02:30:15 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:54:39 +0000
commit2645dae1c206cd25dd48fc126f368c525d80a5fd (patch)
treeca4161346be07db846332c724b52d4a5cbc1e5d6 /main/xhost
parent14080c41deed5902934e50e0052efcc2f1fe620a (diff)
downloadaports-2645dae1c206cd25dd48fc126f368c525d80a5fd.tar.bz2
aports-2645dae1c206cd25dd48fc126f368c525d80a5fd.tar.xz
main/xhost: modernise, fix deps, add tests
Diffstat (limited to 'main/xhost')
-rw-r--r--main/xhost/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/main/xhost/APKBUILD b/main/xhost/APKBUILD
index 77bc0cd73e..e2bbfdda4a 100644
--- a/main/xhost/APKBUILD
+++ b/main/xhost/APKBUILD
@@ -1,31 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xhost
pkgver=1.0.7
-pkgrel=0
+pkgrel=1
pkgdesc="Controls host and/or user access to a running X server."
url="http://xorg.freedesktop.org/"
arch="all"
license="custom"
subpackages="$pkgname-doc"
depends=
-makedepends="libx11-dev libxmu-dev libxau-dev"
+makedepends="libx11-dev libxmu-dev libxau-dev util-macros"
source="http://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
-
-build () {
+build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="670a8c97291565f6c36c94e135f7bd60a572bb42b4fca9d2460823db0d0576187c64f9b876ed60d348029d3f74a732862eea4ce889a6b6b9c97665746a38b1d7 xhost-1.0.7.tar.bz2"