aboutsummaryrefslogtreecommitdiffstats
path: root/main/xtrabackup/Werror.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-04 10:34:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-04 10:34:48 +0000
commitd3da5b4c5af7ad9550a7521031f2546e3c645d7c (patch)
tree90f18ae501b11575ee318578ab13f89e8ba48bdf /main/xtrabackup/Werror.patch
parent417f467538e0b0363fb8914c6fd73556cba4cc28 (diff)
downloadaports-d3da5b4c5af7ad9550a7521031f2546e3c645d7c.tar.bz2
aports-d3da5b4c5af7ad9550a7521031f2546e3c645d7c.tar.xz
main/xtrabackup: fix build
work around -Werror
Diffstat (limited to 'main/xtrabackup/Werror.patch')
-rw-r--r--main/xtrabackup/Werror.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/xtrabackup/Werror.patch b/main/xtrabackup/Werror.patch
new file mode 100644
index 0000000000..ae94f09878
--- /dev/null
+++ b/main/xtrabackup/Werror.patch
@@ -0,0 +1,11 @@
+--- ./src/libarchive/CMakeLists.txt.orig
++++ ./src/libarchive/CMakeLists.txt
+@@ -843,7 +843,7 @@
+ # aggressive about diagnosing build problems; this can get
+ # relaxed somewhat in final shipping versions.
+ IF ("CMAKE_C_COMPILER_ID" MATCHES "^GNU$")
+- ADD_DEFINITIONS(-Wall -Werror)
++ ADD_DEFINITIONS(-Wall)
+ ENDIF ("CMAKE_C_COMPILER_ID" MATCHES "^GNU$")
+
+ IF(ENABLE_TEST)