aboutsummaryrefslogtreecommitdiffstats
path: root/main/xulrunner/fix-toolkit.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-19 18:01:35 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-19 18:01:35 +0000
commitd4c94d84fa09bdd58fc0413a958966caa13c5f84 (patch)
tree35a6ce0d6199dbcde926af0da2354d851c73f0ef /main/xulrunner/fix-toolkit.patch
parent0a87c68d217e72e9d823fb00f11047bab47b914f (diff)
downloadaports-d4c94d84fa09bdd58fc0413a958966caa13c5f84.tar.bz2
aports-d4c94d84fa09bdd58fc0413a958966caa13c5f84.tar.xz
main/xulrunner: rebase musl patches, and fix musl build
Diffstat (limited to 'main/xulrunner/fix-toolkit.patch')
-rw-r--r--main/xulrunner/fix-toolkit.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/main/xulrunner/fix-toolkit.patch b/main/xulrunner/fix-toolkit.patch
new file mode 100644
index 0000000000..c572189518
--- /dev/null
+++ b/main/xulrunner/fix-toolkit.patch
@@ -0,0 +1,88 @@
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
+@@ -45,6 +45,7 @@
+ #include <sys/mman.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
++#include <libgen.h>
+
+ #include <iostream>
+ #include <set>
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.cc
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.cc
+@@ -41,6 +41,10 @@
+
+ #include "common/using_std_string.h"
+
++#ifndef N_UNDF
++#define N_UNDF 0
++#endif
++
+ using std::vector;
+
+ namespace google_breakpad {
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.h
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.h
+@@ -53,9 +53,10 @@
+ #include <config.h>
+ #endif
+
+-#ifdef HAVE_A_OUT_H
++#if 0
+ #include <a.out.h>
+ #endif
++
+ #ifdef HAVE_MACH_O_NLIST_H
+ #include <mach-o/nlist.h>
+ #endif
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
+@@ -2813,7 +2813,7 @@
+ LSS_INLINE _syscall6(void*, mmap, void*, s,
+ size_t, l, int, p,
+ int, f, int, d,
+- __off64_t, o)
++ off_t, o)
+
+ LSS_INLINE _syscall4(int, newfstatat, int, d,
+ const char *, p,
+--- mozilla-release/toolkit.orig/library/Makefile.in
++++ mozilla-release/toolkit/library/Makefile.in
+@@ -423,7 +423,7 @@
+
+
+ ifdef MOZ_CUBEB
+-ifdef MOZ_ALSA
++ifdef MOZ_ALSA_LIBS
+ EXTRA_DSO_LDOPTS += $(MOZ_ALSA_LIBS)
+ endif
+ ifdef MOZ_PULSEAUDIO
+--- mozilla-release/toolkit.orig/mozapps/update/common/updatedefines.h
++++ mozilla-release/toolkit/mozapps/update/common/updatedefines.h
+@@ -105,7 +105,7 @@
+
+ #ifdef SOLARIS
+ # include <sys/stat.h>
+-#else
++#elif !defined(__linux__) || defined(__GLIBC__)
+ # include <fts.h>
+ #endif
+ # include <dirent.h>
+--- mozilla-release/toolkit.orig/mozapps/update/updater/updater.cpp
++++ mozilla-release/toolkit/mozapps/update/updater/updater.cpp
+@@ -3422,6 +3422,7 @@
+ int add_dir_entries(const NS_tchar *dirpath, ActionList *list)
+ {
+ int rv = OK;
++#if !defined(__linux__) || defined(__GLIBC__)
+ FTS *ftsdir;
+ FTSENT *ftsdirEntry;
+ NS_tchar searchpath[MAXPATHLEN];
+@@ -3524,6 +3525,7 @@
+ }
+
+ fts_close(ftsdir);
++#endif
+
+ return rv;
+ }