aboutsummaryrefslogtreecommitdiffstats
path: root/main/xulrunner/uclibc-malloc_usable_size.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-17 15:03:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-17 15:03:52 +0000
commit60a4a411107ea85ae1c88ed4b1a3bec5840dfad0 (patch)
tree05bcc208c8748093cad9be69fa4e7199b0aa0038 /main/xulrunner/uclibc-malloc_usable_size.patch
parent29108eff93d25510d7095cc147a7cea36b4e0c6a (diff)
downloadaports-60a4a411107ea85ae1c88ed4b1a3bec5840dfad0.tar.bz2
aports-60a4a411107ea85ae1c88ed4b1a3bec5840dfad0.tar.xz
main/xulrunner: upgrade to 17.0.1
Diffstat (limited to 'main/xulrunner/uclibc-malloc_usable_size.patch')
-rw-r--r--main/xulrunner/uclibc-malloc_usable_size.patch34
1 files changed, 17 insertions, 17 deletions
diff --git a/main/xulrunner/uclibc-malloc_usable_size.patch b/main/xulrunner/uclibc-malloc_usable_size.patch
index 4d088787c3..49b5a6430e 100644
--- a/main/xulrunner/uclibc-malloc_usable_size.patch
+++ b/main/xulrunner/uclibc-malloc_usable_size.patch
@@ -1,6 +1,19 @@
+--- mozilla-release-old/memory/mozalloc/Makefile.in
++++ mozilla-release/memory/mozalloc/Makefile.in
+@@ -43,6 +43,10 @@
+
+ include $(DEPTH)/config/autoconf.mk
+
++ifdef MOZ_MEMORY
++SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc) $(call EXPAND_LIBNAME_PATH,memory,../build)
++endif
++
+ VISIBILITY_FLAGS=
+ STL_FLAGS =
+ ifdef _MSC_VER
--- ./memory/mozalloc/mozalloc.cpp.orig
+++ ./memory/mozalloc/mozalloc.cpp
-@@ -63,7 +63,7 @@
+@@ -33,7 +33,7 @@
#include "mozilla/mozalloc_oom.h" // for mozalloc_handle_oom
/* Windows doesn't have malloc_usable_size, but jemalloc has */
@@ -9,12 +22,12 @@
extern "C" size_t malloc_usable_size(const void *ptr);
#endif
-@@ -243,10 +243,10 @@
+@@ -213,10 +213,10 @@
#if defined(XP_MACOSX)
return malloc_size(ptr);
--#elif defined(MOZ_MEMORY) || (defined(XP_LINUX) && !defined(ANDROID))
-+#elif defined(MOZ_MEMORY) || (defined(XP_LINUX) && !defined(ANDROID) &&!defined(__UCLIBC__))
+-#elif defined(MOZ_MEMORY) || (defined(XP_LINUX) && !defined(ANDROID)) || defined(__FreeBSD__)
++#elif defined(MOZ_MEMORY) || (defined(XP_LINUX) && !defined(ANDROID)) && !defined(__UCLIBC__) || defined(__FreeBSD__)
// Android bionic libc doesn't have malloc_usable_size.
return malloc_usable_size(ptr);
-#elif defined(XP_WIN)
@@ -22,16 +35,3 @@
return _msize(ptr);
#else
return 0;
---- mozilla-release-old/memory/mozalloc/Makefile.in
-+++ mozilla-release/memory/mozalloc/Makefile.in
-@@ -43,6 +43,10 @@
-
- include $(DEPTH)/config/autoconf.mk
-
-+ifdef MOZ_MEMORY
-+SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc) $(call EXPAND_LIBNAME_PATH,memory,../build)
-+endif
-+
- VISIBILITY_FLAGS=
- STL_FLAGS =
- ifdef _MSC_VER