aboutsummaryrefslogtreecommitdiffstats
path: root/main/zfs-grsec
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-24 20:54:51 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-11-24 20:55:30 +0000
commit10ce1b0a4fc29b703a5faba3abba088e5f53b249 (patch)
tree3e4b7576ba5d7aa58bb4edc5504d9cc48d939542 /main/zfs-grsec
parent7ce2480f04c230349c5229b4d185d5e627a47f4e (diff)
downloadaports-10ce1b0a4fc29b703a5faba3abba088e5f53b249.tar.bz2
aports-10ce1b0a4fc29b703a5faba3abba088e5f53b249.tar.xz
main/zfs-grsec: rebuild against kernel 4.4.34-r3
Diffstat (limited to 'main/zfs-grsec')
-rw-r--r--main/zfs-grsec/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/main/zfs-grsec/APKBUILD b/main/zfs-grsec/APKBUILD
index c9e690bb1d..c128d4466a 100644
--- a/main/zfs-grsec/APKBUILD
+++ b/main/zfs-grsec/APKBUILD
@@ -7,7 +7,7 @@ _name=$_realname-$_flavor
_kpkg=linux-$_flavor
_kver=4.4.34
-_kpkgrel=2
+_kpkgrel=3
_realver=0.6.5.8
_mypkgrel=0
@@ -59,8 +59,7 @@ prepare() {
build() {
cd "$builddir"
export LIBS="$LIBS -lintl"
- KCFLAGS="-fno-pie" \
- EXTRA_KCFLAGS="-fno-pie -Wno-error=unused-but-set-variable" \
+ EXTRA_KCFLAGS="-Wno-error=unused-but-set-variable" \
./configure --prefix=/usr \
--with-tirpc \
--sysconfdir=/etc \
@@ -71,14 +70,12 @@ build() {
--with-linux=/usr/src/linux-headers-${_abi_release} \
--with-spl=/usr/src/spl-${_realver} \
|| return 1
- make KCFLAGS="-fno-pie" \
- EXTRA_KCFLAGS="-fno-pie" \
- || return 1
+ make || return 1
}
package() {
cd "$builddir"
- make KCFLAGS="-fno-pie" DESTDIR="$pkgdir" \
+ make DESTDIR="$pkgdir" \
install || return 1
}