aboutsummaryrefslogtreecommitdiffstats
path: root/main/zsh/APKBUILD
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2015-09-08 18:51:30 +0000
committerEivind Uggedal <eivind@uggedal.com>2015-09-08 18:56:06 +0000
commit7bd1be45cfdf63cae772372c7ea4d039d19e33fb (patch)
treec52a97ede6b80476e3356641a81a087515c5f824 /main/zsh/APKBUILD
parent035d8515ff1e55c5dec7171a72b31bd97eb5f7cb (diff)
downloadaports-7bd1be45cfdf63cae772372c7ea4d039d19e33fb.tar.bz2
aports-7bd1be45cfdf63cae772372c7ea4d039d19e33fb.tar.xz
main/zsh: fix loading of provided zprofile
With `--enable-etcdir=/etc/zsh` zprofile needs to be installed to /etc/zsh. Also remove unnecessary configure flags for zshenv/zlogin/zlogout/zshrc since they mathed defaults when etcdir is enabled.
Diffstat (limited to 'main/zsh/APKBUILD')
-rw-r--r--main/zsh/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/main/zsh/APKBUILD b/main/zsh/APKBUILD
index 840ef7571e..45bc2d1ff3 100644
--- a/main/zsh/APKBUILD
+++ b/main/zsh/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=zsh
pkgver=5.0.8
-pkgrel=0
+pkgrel=1
pkgdesc="A very advanced and programmable command interpreter (shell)"
url="http://www.zsh.org/"
arch="all"
@@ -29,10 +29,6 @@ build() {
--prefix=/usr \
--bindir=/bin \
--enable-etcdir=/etc/zsh \
- --enable-zshenv=/etc/zsh/zshenv \
- --enable-zlogin=/etc/zsh/zlogin \
- --enable-zlogout=/etc/zsh/zlogout \
- --enable-zshrc=/etc/zsh/zshrc \
--enable-multibyte \
--enable-function-subdirs \
--enable-zsh-secure-free \
@@ -47,7 +43,7 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
- install -Dm644 "$srcdir"/zprofile "$pkgdir"/etc/zprofile
+ install -Dm644 "$srcdir"/zprofile "$pkgdir"/etc/zsh/zprofile
}
md5sums="e6759e8dd7b714d624feffd0a73ba0fe zsh-5.0.8.tar.bz2