aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-05-01 23:22:38 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-02 15:34:54 +0200
commit12e13968b80892f0a78bfba308aeb7cb060d1d40 (patch)
tree2d89a7c26fcd3673f99747198069c65bbf0d0724 /main
parente2207f9276d616ba2ba2c70781c6e28ba49eca4a (diff)
downloadaports-12e13968b80892f0a78bfba308aeb7cb060d1d40.tar.bz2
aports-12e13968b80892f0a78bfba308aeb7cb060d1d40.tar.xz
testing/ssh-getkey-ldap: move to the main repo
Diffstat (limited to 'main')
-rw-r--r--main/ssh-getkey-ldap/APKBUILD27
-rw-r--r--main/ssh-getkey-ldap/ssh-getkey-ldap.post-install11
2 files changed, 38 insertions, 0 deletions
diff --git a/main/ssh-getkey-ldap/APKBUILD b/main/ssh-getkey-ldap/APKBUILD
new file mode 100644
index 0000000000..5d00dba6ec
--- /dev/null
+++ b/main/ssh-getkey-ldap/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ssh-getkey-ldap
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A simple script to be used as AuthorizedKeysCommand in OpenSSH server to look up user's public keys in LDAP."
+url="https://github.com/jirutka/ssh-getkey-ldap"
+arch="noarch"
+license="MIT"
+depends="lua-ldap"
+makedepends=""
+install="$pkgname.post-install"
+source="$pkgname-$pkgver.tar.gz::http://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ exit 0
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" PREFIX="/usr" ./install
+}
+
+md5sums="5eb480083707e16ce05df7e5692092bb ssh-getkey-ldap-0.1.0.tar.gz"
+sha256sums="609880ae1f0363ce6e05d8d4533ccc5472dc883e7da2b1b90dc81216558d3b59 ssh-getkey-ldap-0.1.0.tar.gz"
+sha512sums="4cf657a5a6bfde243f1db309d52d15b926c9b4c33d35336d1aa8460d62b841012696798a9913f62fa2020680eaa59954aeab449677fa990528ccae2172d9d59b ssh-getkey-ldap-0.1.0.tar.gz"
diff --git a/main/ssh-getkey-ldap/ssh-getkey-ldap.post-install b/main/ssh-getkey-ldap/ssh-getkey-ldap.post-install
new file mode 100644
index 0000000000..e5183e1d88
--- /dev/null
+++ b/main/ssh-getkey-ldap/ssh-getkey-ldap.post-install
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+cat <<EOF 1>&2
+*
+* If you want OpenSSH server to look up user's public keys in LDAP,
+* add the following lines to /etc/ssh/sshd_config and reload sshd:
+*
+* AuthorizedKeysCommand /usr/bin/ssh-getkey-ldap
+* AuthorizedKeysCommandUser nobody
+*
+EOF