aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-22 17:32:36 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-22 17:32:36 +0200
commit20bf5ed84f79313f4238ddd01072ce5fd4c45736 (patch)
tree21317acdbdc83a6c750de7faa43f01f9b36b02ae /main
parent2be56e8d2878b588866c12b08b13dfc714ce52fd (diff)
downloadaports-20bf5ed84f79313f4238ddd01072ce5fd4c45736.tar.bz2
aports-20bf5ed84f79313f4238ddd01072ce5fd4c45736.tar.xz
testing/pcmanfm: move to main with dependencies
Diffstat (limited to 'main')
-rw-r--r--main/libfm/APKBUILD34
-rw-r--r--main/menu-cache/APKBUILD32
-rw-r--r--main/pcmanfm/APKBUILD31
3 files changed, 97 insertions, 0 deletions
diff --git a/main/libfm/APKBUILD b/main/libfm/APKBUILD
new file mode 100644
index 0000000000..bcdf3465ea
--- /dev/null
+++ b/main/libfm/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=libfm
+pkgver=1.1.2.2
+pkgrel=0
+pkgdesc='Library for file management'
+url='http://pcmanfm.sourceforge.net/'
+arch='all'
+license='GPL'
+makedepends='gtk+2.0-dev menu-cache-dev udisks-dev intltool dbus-glib-dev'
+options='libtool'
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-udisks \
+ --with-gnu-ld || return 1
+ make LDFLAGS+=' -lgobject-2.0 -lglib-2.0' || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+
+ rm "$pkgdir"/usr/include/libfm
+ mv "$pkgdir"/usr/include/libfm-1.0/ "$pkgdir"/usr/include/libfm
+}
+
+md5sums="ea3d09b23ef4c37cb84ae57ea16b8f08 libfm-1.1.2.2.tar.gz"
+sha256sums="158e2b6974350d2dab15932b496bb4d448553e60bbf7cdfe4d6e9bd99d19d682 libfm-1.1.2.2.tar.gz"
+sha512sums="0c50210432a70f18033df2ce2fc20ce84f987e5efc8a4e7341aa6b7076f132407765257eeaacbc5cd7f81a11465049a2f8c460444bf54f2707b6bd04d3a34239 libfm-1.1.2.2.tar.gz"
diff --git a/main/menu-cache/APKBUILD b/main/menu-cache/APKBUILD
new file mode 100644
index 0000000000..db572b60ac
--- /dev/null
+++ b/main/menu-cache/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=menu-cache
+pkgver=0.5.1
+pkgrel=1
+pkgdesc='Caching mechanism for freedesktop.org compliant menus'
+arch='all'
+license='GPL2'
+url='http://lxde.org/'
+makedepends='glib-dev'
+options='libtool'
+source="http://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib/menu-cache \
+ --disable-static || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fd296c317a235782fbbd37b6f54bc985 menu-cache-0.5.1.tar.gz"
+sha256sums="08e658021faecd4eefb26cc21b207251a6b4e844e131cec491471aba9eaea122 menu-cache-0.5.1.tar.gz"
+sha512sums="44d55a01f5452804e77518c4a2ba400a5b65edbf4061e346a6c02356195867eaa0bb9eaa057fbf603ddf79759acb16632bf3b7ae543eebc1544e28517cd23066 menu-cache-0.5.1.tar.gz"
diff --git a/main/pcmanfm/APKBUILD b/main/pcmanfm/APKBUILD
new file mode 100644
index 0000000000..efb32f0d12
--- /dev/null
+++ b/main/pcmanfm/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=pcmanfm
+pkgver=1.1.2
+pkgrel=0
+pkgdesc='Extremely fast and lightweight file manager'
+arch='all'
+url='http://pcmanfm.sourceforge.net/'
+license='GPL'
+makedepends='gtk+2.0-dev libfm-dev intltool'
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --sysconfdir=/etc --prefix=/usr || return 1
+ make LDFLAGS+=' -lm' || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+
+ sed -i 's|x-directory/normal|inode/directory|' \
+ "$pkgdir"/usr/share/applications/pcmanfm.desktop || return 1
+}
+
+md5sums="41104699e653ff2b0a9a9e80a257d6a2 pcmanfm-1.1.2.tar.gz"
+sha256sums="23ee33b34066ac83ce9a98bc9930049e69839438fb60489bd453bec8c2068950 pcmanfm-1.1.2.tar.gz"
+sha512sums="0640919477bef8a88b76eb96aaf7f261c423189b60b27f720514040b4006ab5d9d30db5f25380320efc322ca2631298c72ee52a92bebf11ebf162eaa577058e1 pcmanfm-1.1.2.tar.gz"