aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-07-06 11:56:16 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-07-06 13:00:47 +0200
commit6021759f27b400ec7c77638f1d600a036e03c2a8 (patch)
treec491a51d6f6a501a342d3dfda8ba6f6cde7f31bb /main
parent7ee606ed18c69574f68085ce826954daec486737 (diff)
downloadaports-6021759f27b400ec7c77638f1d600a036e03c2a8.tar.bz2
aports-6021759f27b400ec7c77638f1d600a036e03c2a8.tar.xz
main/unzip: fix installation of man pages
And cleanup a bit.
Diffstat (limited to 'main')
-rw-r--r--main/unzip/APKBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/main/unzip/APKBUILD b/main/unzip/APKBUILD
index b93e5930f1..a38ffc22f0 100644
--- a/main/unzip/APKBUILD
+++ b/main/unzip/APKBUILD
@@ -1,7 +1,8 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=unzip
pkgver=6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Extract PKZIP-compatible .zip files"
url="http://www.info-zip.org/UnZip.html"
arch="all"
@@ -13,29 +14,23 @@ source="ftp://ftp.info-zip.org/pub/infozip/src/${pkgname}60.zip
10-unzip-handle-pkware-verify.patch
20-unzip-uidgid-fix.patch
unzip-6.0-heap-overflow-infloop.patch
-
"
-_builddir="$srcdir"/${pkgname}60
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir"/${pkgname}60
build() {
- cd "$_builddir"
- make -f unix/Makefile LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" prefix=/usr generic || return 1
+ cd "$builddir"
+ make -f unix/Makefile \
+ LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" \
+ prefix=/usr generic || return 1
}
package() {
- cd "$_builddir"
- make -f unix/Makefile prefix=${pkgdir}/usr MANDIR=${pkgdir}/usr/share/man install || return 1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd "$builddir"
+ make -f unix/Makefile \
+ MANDIR=${pkgdir}/usr/share/man/man1/ \
+ prefix=${pkgdir}/usr install || return 1
+ install -Dm644 LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
md5sums="85da5203f01ab0b9403efef3b9bb4010 unzip60.zip