aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-09-07 01:27:54 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2015-09-09 07:44:15 +0000
commitf0cd3fa512b13e3dba57c9cfa8afb653637bd459 (patch)
tree1ed0d0bc9bac85a13325354b3abb4689be1a1a4c /main
parent21ec2c0ad64c7e8c8abc3cefcec35227b679960c (diff)
downloadaports-f0cd3fa512b13e3dba57c9cfa8afb653637bd459.tar.bz2
aports-f0cd3fa512b13e3dba57c9cfa8afb653637bd459.tar.xz
main/go-bootstrap: install to /usr/lib/go-bootstrap
To avoid that $GOROOT_BOOTSTRAP equals $GOROOT during main/go build. See: - https://github.com/golang/go/commit/f9379eb3467d2b6feb8fb0c7c2c366b81408305d Also: Cleanup package further and fix removal of _test.go packages.
Diffstat (limited to 'main')
-rw-r--r--main/go-bootstrap/APKBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/main/go-bootstrap/APKBUILD b/main/go-bootstrap/APKBUILD
index 558cb81cb5..eadad50f0f 100644
--- a/main/go-bootstrap/APKBUILD
+++ b/main/go-bootstrap/APKBUILD
@@ -4,18 +4,17 @@
pkgname=go-bootstrap
_realname="${pkgname%-*}"
pkgver=1.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="Go programming language compiler used for bootstraping"
url="http://www.golang.org/"
arch="x86_64 armhf"
license="BSD"
-replaces="go"
depends=""
depends_dev=""
-makedepends="bash perl"
+makedepends="bash"
options="!strip"
install=""
-subpackages="$pkgname-doc"
+subpackages=""
source="
https://storage.googleapis.com/golang/go${pkgver}.src.tar.gz
no-werror.patch
@@ -41,7 +40,7 @@ build() {
export GOPATH="$srcdir"
export GOROOT="$_builddir"
export GOBIN="$GOROOT"/bin
- export GOROOT_FINAL=/usr/lib/go
+ export GOROOT_FINAL=/usr/lib/$pkgname
case "$CARCH" in
x86) export GOARCH="386" ;;
@@ -50,7 +49,6 @@ build() {
*) return 1 ;;
esac
- unset CC # ccache breaks build for some reason
./make.bash --no-clean || return 1
# FIXME: race and bench tests fail:
@@ -59,19 +57,20 @@ build() {
package() {
cd "$_builddir"
- mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib/go "$pkgdir"/usr/share/doc/go
+ mkdir -p "$pkgdir"/usr/lib/$pkgname "$pkgdir"/usr/lib/$pkgname
# The source needs to be installed due to an upstream
# bug (https://github.com/golang/go/issues/2775).
- # When this is resolved we can split out the source to a
- # go-doc sub package.
- cp -a bin pkg src "$pkgdir"/usr/lib/go || return 1
- cp -r doc misc "$pkgdir"/usr/share/doc/go || return 1
+ cp -a bin pkg src "$pkgdir"/usr/lib/$pkgname || return 1
- # Remove tests from /usr/lib/go/src.
+ # Remove tests and bashscripts from /usr/lib/go/src.
# Those shouldn't be affacted by the upstream bug (see above).
- find "$pkgdir"/usr/lib/go \( -type f -a -iname '*_test*' \) \
- -o \( -type d -name 'testdata' \) -exec rm -rf \{\} \+
+ find "$pkgdir"/usr/lib/$pkgname/src \( -type f -a -name "*_test.go" \) \
+ -exec rm -rf \{\} \+ || return 1
+ find "$pkgdir"/usr/lib/$pkgname/src \( -type d -a -name "testdata" \) \
+ -exec rm -rf \{\} \+ || return 1
+ find "$pkgdir"/usr/lib/$pkgname/src \( -type f -a -name "*.bash" \) \
+ -exec rm -rf \{\} \+ || return 1
}
md5sums="907f85c8fa765d31f7f955836fec4049 go1.4.2.src.tar.gz