aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-16 14:21:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-16 14:22:55 +0000
commit989ce1eb46e655bfbc5be4812b185f8ea250728a (patch)
treeef3a3e7323976ac643d7d48629246d992fde75ad /main
parent4e061d85be7a7954560299b42e32bc99ce0e691a (diff)
downloadaports-989ce1eb46e655bfbc5be4812b185f8ea250728a.tar.bz2
aports-989ce1eb46e655bfbc5be4812b185f8ea250728a.tar.xz
main/which: move from testing
Diffstat (limited to 'main')
-rw-r--r--main/which/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/which/APKBUILD b/main/which/APKBUILD
new file mode 100644
index 0000000000..1f40f5ad0e
--- /dev/null
+++ b/main/which/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=which
+pkgver=2.21
+pkgrel=0
+pkgdesc="A utility to show the full path of commands"
+url="http://savannah.gnu.org/projects/which"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="097ff1a324ae02e0a3b0369f07a7544a which-2.21.tar.gz"
+sha256sums="f4a245b94124b377d8b49646bf421f9155d36aa7614b6ebf83705d3ffc76eaad which-2.21.tar.gz"
+sha512sums="d2f04a5c5291f2d7d1226982da7cf999d36cfe24d3f7bda145508efcfb359511251d3c68b860c0ddcedd66b15a0587b648a35ab6d1f173707565305c506dfc61 which-2.21.tar.gz"